[SOLVED] Firmware update with OpenROV-2.5-05 image

solved
sos
electronics

#1

Hi,

last few days I have been trying to get my ROV running, I can not get arduino to communicate with BBB.

Has someone tried to create SD card image based on OpenROV-2.5-05.img.7z and successfully updated arduino software via the browser / cockpit settings?

I am using the SD card with OpenROV-2.5-05.img.7z image and controller board Rev 2.6.

The Linux is booting, SSH works and I can access cockpit via browser. Arduino is alive, I have even managed to upload firmware via USBTiny ISP programmer but it just can not communicate with BBB.

Any help would be more than appreciated.

Kind regards,

Grega


#2

Hi Grega

I used the image that was available and burned it onto the SDcard using my windows system and Win32 Disk Imager. Once installed in the BBB and attached to the 2.6 Controller it uploaded the Arduino Code from the SDcard with no issue.


#3

Hi David,

finally my Controller board and BBB are communicating. Friend of mine suggested that maybe the fuses are set wrong on the AVR.

AVR - ATMega 2650 has internal fuse bytes to set clock source.

The problem was that mine had fuses set to internal oscillator clock and also "divide clock by 8" was set. When I changed the fuses to external clock and disabled "divide clock by 8", the problem was solved. BBB started to talk to the Arduino :)

Now I just need to put ESCs back on and connect all together.

- Grega


#4

Wow congratulations!! good catch on the fuse settings.


#5