[solved] ESC programming and calibration

solved
sos

#1

Hello,


I am building an OpenROV 2.6, I programmed the ESCs successfully (changes were saved after switch off)


However when I proceeded to calibration (I calibrated one ESC while the 2 other and the servo are unplugged) all motors start running.

Now after calibrating all 3, no matter which ESC I turn on, all motors start running.

I tried re-calibrating with all ESCs plugged in but while switching only 1 at a time. Same behavior.

LEDs on all the ESCs keep flashing as soon as I turn any of them on.

Help is much appreciated. Thank you.


#2

Ray has a good blog post worth reading: http://rayhightower.com/blog/2014/08/21/esc-programming-and-calibration-for-openrov/

Recommendation on physically disconnecting the other motors when calibrating: http://community.openrov.com/forum/topics/esc-doesnt-enter-programming-mode?commentId=6365107%3AComment%3A101967


#3

I had exactly the same symptoms described by Ray, I fixed it by reprogramming the Arduino and then re-calibrating the ESCs (also rechecking the programming) while having only 1 ESC connected at a time


#4