[solved] esc doesnt enter programming mode

solved
sos

#1

I have been able to program 2 engines but when I try to enter programming mode with the last motor it instead starts and no biiping. What can be wrong? The connection looks ok..


#2

Have you tried to connect the the ESC to one of the (working) connections on the rov board to eliminate if there is something wrong with the board.


#3

Thanks for the tip! Ill test that but as Im rereading the assembly instruction for the esc - at step 57 it says that the middle esc controles the vertical motor and that it connects to D7. But it was the middle esc I was unable to program - but it started the starboard motor(left when viewed from behind) not the vertical motor when I turned it on - and I have it connected to D7.


This is different then what it says in step 57: "the Vertical ESC (the middle ESC, labled ESC-2) should plug into D7"


#4

Strange things can happen with the ESCs, since when you turn one on, it feeds power to the other two as well, via the battery eliminator circuit (BEC). When you program and calibrate the ESCs, I would recommend that you have only one servo lead plugged in at a time. Only plug all three into the controller board once you have all three ESCs programmed and calibrated. This should eliminate the issues you're seeing.

-W


#5

Thanks for the tips! Here's what I did:

1. I rearranged the connections (d6-d8) connections as suggested by Kjetil and was able to get to programming mod with all the motors

2. arranged the connections in correct order and was also able to get in programming mod.

3. programmed the ESCs - but as I calibrated the ESCs - afterwards turning them on would turn on multiple motors

4. I follows Walt's suggestion and programmed the ESCs with only one connected at a time.

5. I tried calibrating the ESCs all connected at the same time - but got same results as in 3.

6. calibrated them - one ESC connected at a time.

7. Tested them. Port motor would not revers

8. Realized port motor had reset its programming. Reprogrammed and calibrated it with all ESCs connected. Success.


#6

We also had trouble with an ESC losing programming. You can hear it brake (sounds like a ding), it doesn't reverse, etc. We're replacing two of the ESCs (with the same parts) before our first real dive!

If anyone has replaced the ESCs with another brand, what did you go with?

http://jacobswellproject.blogspot.com/


#7

ah - ok so thats what that sound meant.


#8