[solved] Electronics: Controller not powering BBB or Comm board

solved
electronics

#1

Hi OpenROVers,

New to the website. I am having some wiring issues with my OpenROV 2.6. I have observed a constellation of symptoms that hopefully makes the issue specific. Would greatly appreciate any help on this, it is my first solo electronics project.

I check the voltages on the 25-pin connector, all perfect (12 V for both power supplies, 5 V on the tether). These are always perfect.

My ESCs receive voltage (12V) on their 2 electrodes, I can tell by testing the backside of the board. However, they display a constant red LED and do not respond to holding down the "set" button.

I get good voltages at several points on the controller board (D11, J12, J17) but get no voltage for the checkpoints at the center of the controller board (where the comm board connects).

In J6, where the BBB connects, I get 0.8V between pins 1 and 3, and nothing else.

I can power on the BBB and view the webcam when I plug the topside adapter's powercord into the BBB (powering it directly) so I don't think it is a BBB issue.

While none of the 25-pins seem to short when I test with multimeter, I do see that the motor A/B/C pins all seem to be connected (shorted?). Is this normal? It seems like they all touch each other within the bell of the motor and it would be very hard to prevent that with the shrink tubing.

Lastly, I noticed that sometimes when I power up, or toggle an ESC on/off switch, or accidentally touch two parts of the board with a multimeter probe, the ESC lights shut off and 25-pin voltage, when measured from the pin nubs on the back of the controllerboard, sinks from 12V to 2V. If I unplug the 25-pin and test it directly, it is 12 V, but plugging it in causes a sink to 2V. The 2V measurement on the back of the board persists even while the 25-pin plug is unplugged (capacitors discharging slowly)? Usually if I wait awhile, I can re-plug the 25-pin and go back to normal 12V and solid red ESC lights. Maybe an intermittent short?

So to recap the observable symptoms:

1) Solid red ESCs unresponsive to set button

2) Normal voltages around perimeter of board

3) But no voltage for Comm board pins

4) And only 0.8V for BBB pins (between 1 and 3)

5) Motor A/B/Cs seem to be shorted within the motors

I have seen prior posts indicating this can be a polarity issue, I have tried switching the polarity to no avail and have measured many times.

I have also seen that connecting J17 to J18 can force power to the BBB. I do not have a J18 on this board.

Thanks very much for any help!


#2

Hi Jeremy:

The controller board doesn't power up until it has received a voltage across the tether. You say that there's 5V measured on the tether, so it should be powering up. Do any of the LEDs on the controller board light up? If there is ~12V on the battery terminals and 5V on the tether, then the +5V switching supply should fire up and the PWR LED (green LED1) should be lit. Shorting the pins of J12 together should also get the board to turn on.

I don't understand why you would have 12V on the ESCs if it appears that the rest of the board is off. The ESCs do not have power routed to them until the on-board Arduino boots. The pins of J17 can be shorted to force the ESCs to be powered-up all the time.

I would recommend downloading the schematic for the 2.6 controller board from our Github site (in the openrov-electronics category) to help you with debugging.

Other odds and ends:

The BBB is powered by 5V, not 3.3. If you want to measure the power it's getting, that is between pins 1 and 5. The 0.8V you're seeing sounds like leakage current through the battery-current measurement circuitry, when the board is not powered on.

J18 is one of the connections for the homeplug adapter.

The coil resistance of the motors is only around an ohm or so. That might be why it looks like you have a short. If you are concerned that you actually have a short, take a very careful measurement of the coil resistance and see if it is consistent from motor to motor.

Let us know how things progress.

-W


#3

Hi Walt,

Thanks for your input and sorry for the delayed reply.

I think connecting the J12 and J17 terminals makes sense, but when I went to try, the outer terminals all show 0 voltage. I think my frequent handling may have caused an issue.

Now I get proper 12V voltages at the 21-pin junction (as measured from the reverse of the controller board (so I know that power is going to the board), but 0 voltages everywhere else.

I cannot find an intermediate measurement point between the 12V's and the 0V's to diagnose further. Even the ESCs now show 0 voltage (note, I have removed 2 since they kept coming loose from my handling, and now only one ESC is attached to the board).

Considering buying a new controller board as the issue seems to be taking place within the board (i.e. between the terminals I can measure).

Any thoughts or advice greatly appreciated.


#4

Hi guys,

Update, I tore it apart and rebuilt on a breadboard with a new DB-25 to eliminate any shorts.

Getting 12V for the power pins and 5 V at the tether.

No LEDs turned on until I connected the pins at J12, then I got the attached image (LED2 blinks).

The ESC did not turn on until I connected pins at J17.

J10 now has a 5V across it, J7 has 6V

Still no voltage for pin 1 v pin 5 that feeds the BeagleBone.

Do you know why not and why shorting the switches at J17/J12 was necessary?

Thanks again!

193-controlboard.jpg (177 KB)

#5

So the first thing to figure out is why the power doesn't come on when you apply power to the tether.

I'd first go back and triple-check that you have the tether wired to the correct pins on the DB-25 connector. I can't see the connections on the photo you attached to verify that.

Then I'd download the schematic of the 2.6 controller board from our GitHub site, and trace the tether voltage as it winds its way to optocoupler OC1 (shown on sheet 3 of the schematic). When you short the pins at J12, you are just bypassing Optocoupler OC1.

The ESCs are normally turned on by the software running on the Arduino processor. Since you haven't loaded any software on it yet, it won't turn on the ESCs. Thus you have to jumper J17 to turn them on.

-W


#6

Hi Walt,

Thanks again for the help.

I've made a new DB-25 and ensured that the solder connections are solid and there are no shorts.

I checked the schematic and don't see anything unusual regarding the power circuit. shorting J12 seems to work best, so I've done that. I now get the solid green light (PWR) + solid red light (D13) + blinking red light (D49).

When I attach the communication board to the control board, I also get the leftmost green light (TPWR). The green light is solid, but sometimes goes into a blinking if I disturb the board--it is fairly fragile.

My topbox has a solid green power light and orange Ethernet light as shown.

I once got the HP controller board LED to turn yellow and the central topbox Connection light to also go yellow, but I can't reproduce it.

I measure 4.85V over the tether.

There is 12V across J11 and J17.

My computer will not communicate with the box as shown.

190-lights.jpg (1.95 MB) 191-topbox.jpg (1.41 MB) 192-screen.jpg (1.56 MB)

#7

Hello Jeremy,

I did not read this entire string but did notice one thing that is incorrect when trying to log in.

When setting the static IP address on your computer it should be 192.168.254.2 (the last 2 can be any number other than 1).

The IP address of the ROV is 192.168.254.1 so you have it correct in Google Chrome.

-Brian G.


#8

Hi Brian,

Much obliged for the quick response.

I have tried all 4 combinations of settings and URLs, no dice.

Also, I've tried directly applying 5V to BBB pin sockets 1,5 and cannot get any LED to illuminate on the BBB. I've also tried testing the BBB in isolation by attaching taking the microUSB topside adapter and plugging it into the BBB with the other end in my laptop. I'm concerned the BBB might be fried. Probably downstream of the immediate issue of establishing communication down the tether though.

Sorry to be a bother, fairly n00b


#9

Hello Jeremy,

Just to clarify. You took the BBB off of the rest of the board, plugged the USB into the BBB and the other side into your computer and got no lights on the BBB?

Brian G.


#10

Correct, although the USB end of the cord went into my laptop, and it was a microUSB (cord is not USB on both sides) that connected to the BBB. No lights. Pressing the BBB's reset buttons did nothing.


#11

Hello Jeremy,

This unfortunately sounds like the BBB is not working corectly.

-Brian G.


#12

Thanks for confirming, I will purchase another.

Could this be responsible for the failure of the Homeplug adapters to communicate or do you think it is downstream of the Homeplug problem?


#13

More lights!


Replacing the BBB helped. I can now power the BBB from the controller board (solid blue near power, scrolling blue near the microUSB, orange and green solid on the USB).

LED3 now blinks weak yellow
LED4 illuminates yellow once right before LED3 starts blinking.


I can also attach the BBB ethernet directly to my laptop (powering BBB with microUSB) and successfully see the webcam output in my browser

I think the issue now is that I cannot communicate via the Homeplug adapters. On the topside adapter, I get a green power LED and an orange Ethernet Connect LED and a blank Homeplug connect.
On topside, I get 5V over J3, 0V over J5, and 3V over J4.
On the controller board, I get 4.9V between Tether A and Tether B pins (measured beneath the board)
On the controller board, I get 4.8V over J19, 4.8V over J10, and 3.2V over J18

The cockpit is blank (no connection) when I try to load it through the topside box/controllerboard/bbb


I think the main cause of my troubles has been that I lacked the dexterity to solder my 25 pin DB, caused a short, and fried my first BBB and possible the controller board (had to solder over J12 to power the board, OC1 probably dead). So there could be damage from that.

Also, J7 has no voltage across it on the controller board, even when I connect J17 (which gives me voltage over the ESCs)

As always, much appreciated for following the saga; if you asked, I would happily pay for tech support. For my part, I'm learning more from troubleshooting than I would if it had all just worked out of box.

187-cockpit.PNG (1.49 MB) 188-1.jpg (74.4 KB) 189-2.jpg (62.3 KB)

#14

Hello Jeremy,

Were you ever able to get these problems sorted out? We have recently launched a support system to help customers having problems.

Please feel free to post here or reach out to us through the support channel.

-Brian G.


#15

Hi Brian,

Thanks for reaching out. I’m hoping to know if I’ve resolved the issue
soon.
I bought a new Tanda set (had discarded the wall-plug parts of the first
ones and possibly fried them).
I was able to get real time camera signal by ethernet connecting the BBB to
a Tenda wall plug, communicate through my house’s electrical wiring, and
observe the ROV cockpit on my laptop (connected to the second Tenda).

Therefore, it looks like these Tendas have found each other, so I expect
that when I swap them into the robot, I’ll get communication.

Will post my findings shortly.


#16

Bought new tendas and let them connect to each other via the wall (observed the camera by connecting BBB to one tenda, other to my laptop).
Then put the Tendas in topside box and on controller board
Now I am able to observe the realtime camera feed and even control the lights over the tether!
*Not sure if old Tendas were broken or if they just needed to find eachother’s IP through the wall before using.

Up until this point, I had not attached the ESCs to D6-D8 and also had the wires to the motors themselves disconnected from the 25-pin

I then attache the Port ESC and also connected the 25-pin triplet to the actual motor. Using the controls, I was able to spin the propeller on command as well as raise and lower the camera. I was drawing 0.4A

However, then a weird short appeared. I am using a power supply (instead of a battery, to guard against shorts). I added the other two ESCs, turned it on and had a short (which causes the power supply to flick the power on and off as it hits and then drops current limit). Shutting off power and turning it back on did not resolve the short, only shutting off/removing onboard Tenda/replacing onboard Tenda, caused the short to resolve. It then started shorting after booting up, which made me suspect that attempting to power the ESCs was the problem.

It seems now that when I have the ESCs in and have at least one ESC switch on, the short occurs. If I leave all ESCs off, I can view the webcam and control the lights, but I can no longer move the camera. Obviously with the ESC’s switched off, I can also not spin the propellers. Any of the 3 ESCs cause this short.

Ligating over J17 does not have any effect; there is a voltage of 12V over it though.

When I try to control the motors in any way (up down left right ctrl or shift), BTX illuminates so the signal is getting to the controller board.

I have tried all of the various toggle buttons (like [ to enable ESCs)

There is 12V over the ESC itself (Power and GND) and 0 V over J7 even when I try to move the propellers

The behavior is not 100% consistent. Occassionally, I will have the system set up as described and try an ESC switch (short), try again (short), try again and get a quick burst that moves the webcam servo followed by no short. The cockpit must then reboot because of the intial short (and generally won’t, despite all indicator lights on control board and Tenda lit), but I then get 6V over J7; still cannot use red button to program the ESC. Drawing 0.5A. Restarting power brings back the short.

I don’t see how this could be a soldering issue on the control board, all connections look good.


#17

How many amps are available on your bench supply? You need a good 1.5 to 2A to start up.


#18

Hi badevguru,

I think you nailed the issue. My power supply can only deliver 1A.
I had discarded this theory because, even with all of the ESCs switched off, I could not recover the ability to move the webcam. Similarly, I could not boot up with only one ESC on and control the propeller.

However, I failed to account for the fact that on boot up, simply having the motors connected to the controller board via the 25-pin (even with ESCs off) draws current and was tapping my limit (manifesting as a “short”)

I see now that, if I disconnect the webcam ESC, and turn on one propeller, the propeller spins and 0.8A is drawn. Easy to see how having all 3 going would send me over my current limit.

Theoretically, I can switch to battery power and all will be fine. I’m a bit concerned about frying components if there really is a short though, so I’m going to pick up some fuses first. I’ll check the specs, but to be certain, do you know the robot’s tolerance? You said 2A on startup, but since I’m hitting 0.8A when driving a single propeller, I might need a fuse to tolerate at least 2.4A? Maybe more?

Thanks kindly for your help!


#19

Quick update while waiting for fuses. I was able to test each motor individually by booting up, and then selectively attaching one at a time (to keep current under my 1A power supply limit). Each worked (with some oddities such as the starboard being unwilling to spin in reverse despite the red activator ESC light coming on for it). Might be an issue with programming. Good to see all are working with no shorts though, encourages me that the switch to onboard power will succeed.


#20

Hello Jeremy,

I had a very similar issue with my Starboard motor and spent much time trying to isolate and sort out what I thought was an electrical issue. Turns out, it may be a software glitch. Eric also reported it here https://github.com/OpenROV/openrov-software/issues/334

Try simply Going into and then closing the “Diagnostics” screen as has been reported. Works for me.

~ Charles