[solved] Connects to cockpit but no controls

solved
sos

#1

Hi everyone!

I had everything working… then put the e-chassis into the final clear cylinder and when I try to re-connect, cockpit loads fine, video feed loads fine but if I hit any keys nothing happens…

I checked the DB25 and the power lines were fine, one of the AUX wires had spayed from under the solder and was touching the other AUX’s, but would this affect the power?

Is there anywhere else I should be looking?

I have this at a ROV testing tank tomorrow to demo it to the college it’s been built for so have to get her working again today!

Thanks for the help!!!

J


#2

1. I assume your using Google Chrome.

2. Check to make sure you have full +12V on the control board and I again assume that you are using the proper batteries.

2. Do things work when not in the Tube?

3. Does the camera servo move?

4. try reloading the Ardunio again to make sure it is loaded properly.


#3

Also, make sure the power switches to your ESCs are in the "on" position.

Let us know how it works out- we'll do what we can to help!

E


#4

Thanks everyone for the help here, I'm typing and troubleshooting as I go right now. Have taken the unit out of the tube

- Have fully charged batteries and cockpit is showing 100% 12.1V.

- Currently have numerous indicators in the 'capture' section which were not there before.

- Checked all ESC's, 2 were set to off, now set to on.

- On control board LED1 and LED4 are on/flashing.

Camera is now showing a black screen, no keys on keyboard are working.

Goin to try re-loading the arduino again


#5

YESSSSSS WORKING!!!!!!! When I put the DB25 under a magnifying class 1 single strand of unsoldered wire was crossing onto another!!!!


#6

All controls are working apart from ctrl key won't work the vertical thruster?


#7

Solved, have to hold ctrl down for more than 1 second and it kicks in


#8

If Cockpit comes up but the camera is black, try zeroing the depth gauge. Sounds crazy but it works.

If everything worked before you put it in the tube, then it's likely not the Arduino software. If you're getting updates to the telemetry in the right hand side window of cockpit, then the Arduino is working.

When you say no keys are working, have you tried all the functions, or just the motors? I generally start testing by exercising the lights, as they almost always work if the Arduino is up and running.

-W


#9

Keep losing the ctrl button thruster....


#10

I also have an issue with the ctrl button thruster. Using the keyboard or the Xbox controller same thing. I am using Turnigy ESCs (not the ones that came with the kit) and I have a 2.5 board.


#11

I found a workaround for this, try turning your power up to 5 and then back down and press control it seems to register and kick in!


#12