[SOLVED] Connectivity problem - Intermittent power to homeplug (HPWR)

electronics
sos

#1

I’m in need of some help with a connectivity problem I’m having. (V2.8)

I have followed the assembly instructions, but I am having trouble connecting to the cockpit. t seems the ROV keeps turning On and Off intermittently (HPWR). The homeplug connect led is off, and the other 2 leds are always on. The pwr led on the control board is always on. I have followed the steps on the connectivity troubleshooting, with no success.

Then I measured the resistances on the ESC’s (power off), and here’s what I got:

ESC 1 - Between GND and motor lead 1 - 0 Ohms. Between GND and motor leads 2 and 3 ~20Kohms
Between PWR and motor lead1 - varies from 0 to 6,5 kohms. Between PWR and motor leads 2 and 3 - 26 kohms

ESC 2 and 3 - Between GND and motor leads 1, 2 and 3 - 20kohms
Between PWR and motor leads 1, 2 and 3 - 26kohms

That is not normal behavior for ESC1, right?
Is it safe to say that my connectivity problems are due to ESC1?

And if that is a reasonable suspicion, what should be the next step? Can I just remove ESC1 from the control board and try to connect without it?

Any suggestions would be very much appreciated :smiley:


#2

To describe the situation a little more:

When I plug the USB on-

Homeplug Connect (Topside Interface)-
Power – Green led on
Homeplug Connect – Led off
Ethernet connect – Orange Led on
At the first try, Homeplug Connect was on, and occasionally it turned off, but now it is always off.

Control board-
Pwr – green led always on
HPWR – Green led on for 5s, Off for 2s
Eth – Orange led on when HPWr on, off when HPWR off
Hp – Orange led blinks on when HPR goes off. Rest of the time, Led off.
D13, D49, BTX – Always off
BRX - Blinks very rapidly when HPWR goes off. Otherwise, LED OFF.
Green and orange lights at Ethernet port on BBB - On when HPWR on, off when HPWR off.
When HPWr off, the servo motor from the camera moves a little bit.

Tried to reset both homeplug adapters, I checked voltage from both battery tubes at db25 connector pins (~9,9 v from each), tried switching Ethernet cable, checked voltage at tether pins at db25 connector (5v).Also tried to switch the homeplug adapters from the topside connector to the control board – no changes.


#3

See if this link helps. One problem I found in an intermittent connection of the tether on the topside.

https://openrov.yonyx.com/y/conversation/?id=7c5b2d70-eac3-11e4-a42b-bc764e1028dd&h=1&st=0


#4

Hy Jim,
Thanks for the tip!

I have already tried the steps in the guide with no success, but I think the problem is solved.

I tried a number of things, but what solved it was to short the J17 jumper. Once I did it, the rov started normally and then I could remove the jumper and it started on and off normally. Afterward, it was still not communicating to the cockpit, but resetting the HomePlug adapters this time did the trick.

I’m not sure why shortening J17 solved it, though. I tried it but didn’t have much hope it would work.

Fortunately, it did!


#5

Hi @felipeadachi:

I’m glad things are working for you now.

I’m wondering if you had an issue with some sort of intermittent short-circuit in an ESC/motor, that for whatever reason has now resolved itself.

Normally the ESCs are not powered on until a couple of seconds after the Atmega 2560 has started up. If there is some sort of short circuit in the ESCs or motors, when the ESCs are turned on (via mosfet Q2), the battery voltage will drop, the +5V supply will cut out, the Atmega 2560 will turn off, and Q2 will then turn back off, cutting off the short circuit. The whole cycle then repeats itself over and over again.

When you short across J17, the ESCs are powered on anytime system power is on.

What might have happened is that there was a stray bit of solder causing a short circuit in the one anomalous ESC. When you jumpered J17 and turned the ROV on, high current from the battery eventually burned out that short circuit. Once the short circuit had burned itself out, the ROV would then function normally, even with the jumper on J17 removed.

Just a guess, but it explains the symptoms.

-W