[solved] Communication problem

communication
solved
sos

#1
Hi,

I have just assembled Open-Rov 2.6 but I have no communication via homeplug connector.LED status

-No green & yellow light on the BeagleBone ethernet connector flash up. (Blue lights on the BeagleBone blinking)

-Controllerboard LED8 ETH no light

-Controllerboard LED1 PWR green light

-Controllerboard LED6 TPWR green light

-Controllerboard LED 7 HP yellow blinking light

-Homeplug Powerled green light

-Homeplug Connect yellow blinking light

-Homeplug Ethernet yellow light

Everything seems to work ok if I do the following,

1)I keep the usb between homeplug and PC. And I keep the blue/yellow tether cable connected between homeplug and Rov

2)Then I disconnect the ethernet contact from the "ethernet 200Mbs adapter" attached to the controller board and put it directly into to the PC- So now Beagle Bone speaks directly with the PC.

If I do this I can download program, run motors,turn on light/laser and the camera is working fine.

Tried following error search:

1) I have tried switching ethernet adapters between controller board and homepluge- no improvment

2) Removed all servo connectors and DSub25 and reattached only pin tether pin 18,19 and powercables pin 4,5,6,7-nothing

3) changed ethernet cables

Please- Is there anyone that might have an idea what to do?

I am stuck,

Carl


#2

At last success:)

Continued error searching:

Changed controller board and home plug card –nothing

Separate powered Ethernet homeplugg adapter reseting (12s) factory settings – nothing

Visual Inspection of Ethernet jumper (between homeplug adaptor and Beagle Bone black)- the green wire is in wrong position in one of the BG8s!

(I was pussled about test 3) above since it didn't help that time- must have done something wrong)

Made a new BG8 everything now works fine!

Carl During


#3

Hi Carl:

Glad you were able to find the problem. Let us know how the rest of your build turns out.

-W


#4