[solved] can't get the motors to stop

propulsion
solved
sos
software

#1

Hi

I'm slowing resolving some build issues and now the latest one being the motors once running won't stop for me if I hit the spacebar.

Also is there any way of testing the servo, have my suspicions its not working correctly, its not inside the main tube yet.

Thank you.


#2

Hi James:

Make sure that you've calibrated the ESCs properly. If you have an OpenROV 2.6, see Dozuki step #92.

As for the servo, you can test it with a third-party servo tester, or you can check it out when you are testing everything before putting the electronics in the main tube. Keys Q, A, and Z should move the servo and the attached camera/light bar. Note that the servo will not move if the ESCs are switched off- the servo gets its power from the ESC BECs.

-W


#3

Hi Walt

Reprogrammed the ESC's again and calibrated them too, all seems to work fine but the spacebar does not stop them,they keep on running.I don't know how to control them yet but they seem to be working ok.

I notice on the topside adapter, the power led is green but the other two are always amber,never green,is this related in any way? The homeplug connect one in the middle is usually flashing.

I bought a new servo with metal gears and it functions better but there still is some energy from it not enough to cause movement but a sound which eventually stops.

I have the new batteries showing 540 mA at 9.4v.

Its version 2.6, had to do the programming and calibration with one plugged in at a time and the servo disconnected.

The / does not do anything, should toggle leds.

I see you are from Menlo Park, my Dad's cousin used live on Orange Ave. , did you go to Stanford?

Regards,

James


#4

This morning I powered on but still the same issue, now however the motors only turn when the appropriate key is pressed and don't work continuously,how do i control them are they supposed to just work when the key is pressed and not continuously,I don't know how to fly the unit if I put it into water...and can't find anything in the forums to help me with it.Thanks.


#5

Hey James,

The motors should only turn while the key is pressed. If the keyboard proves inconvenient, a lot of folks enjoy flying with the Logitech F150 gamepad.


#6

Thanks Brian. Since resetting the ESC’s last time I got no continuous motor operation, just key responses. So looks like I’m ready to test in the bath tub to check for leaks and hopefully soon I will take it out to the real world.
James


#7