[solved] Can't connect to ROV, ssh works

solved
software

#1

Hi everyone,

I tested the ROV with the camera before putting the main tube, but after putting on the tube - it no longer boots to a sane state.

Here’s the full status:

BB: USER0 and USER2 blinking irregularily, PWR on

Cape: LED6 green LED7 orange LED8 orange LED1 green, LED4 blinking orange

HP: Power green, HPC orange, Ethernet orange

ROV lights are blinking (where is the code for that?)

ROV version: 2.6 with software image 2.5.1 (RC5)

ping gives “Host is down”

Batteries are fully charged.

Your help would be much appreciated - thanks!

--Paweł

Solution: [solved] Can't connect to ROV, ssh works


#2

I reflashed the BB and can SSH now. All the HTTP requests time out though. Restarting the node.js daemon does not fix the problem. All the board status as on the previous post. I also reset the Tenda adapters.

Can I upload software to Arduino via SSH? Might be that will fix the problem.

Attaching logs.


#3

The problem solved itself after 3 months of disuse.

  1. Suddenly camera and everything came back online.
  2. Tried to put the housing, but lost connection.
  3. Reflashed with 2.5 image.
  4. Pushed together topside adapter boards, which fixed the connection.
  5. All OK except lights start to flash after 3.5 min and logging this:
    CommandBufferOverrun
    log: heading_hold_disabled
  6. Fixed after uploading new Arduino firmware!

#4