[solved] Can't connect to openrov cockpit / "Destination not reachable"

solved
software

#1

So I just got my pre built openrov not to long ago in the mail and was going to start setting it up. The problem I'm facing now is I can't connect to the cockpit page at http://192.168.254.1:8080/ I've tried Chrome and firefox with no luck. Pinging the address 192.168.254.1 results in a "Destination not reachable" It says OpenRov-flash-2.5.1.34 on the flash. The serial is 1628 and interestingly enough on the pre shipping checklist the "Camera and IMU data streams" check is circled unlike the others which are just signed off??

I've heard about issues with the homeplug not working so I disconnected that and plug the ethernet cable directly into beagleboard with no luck :( When I power the rov up after a while the LED lights on the front start blinking. Is that meant to be an indication of when its started up fully? It also says on the beagleboard site that you can connect to it using http://192.168.7.2/ which also didn't work for me. I've also tried connecting without the webcam plugged in but that didn't help. Visually inspected the wiring inside nothing seems wrong. Also checked the ethernet cable I was using for shorts and it seems fine.

So how do I go about troubleshooting this? Also if its a firmware thing then how would I update the firmware when I can't access the cockpit? Any help would be appreciated I'm super excited to get my little robot going but this has just stumped me :(


#2

Has anyone else had this problem? Still looking for help. I see that the troubleshooting guide for this hasn't been completed yet either :( Is there support people I can email??


#3

Hey Jameson,

Do the blue lights on the beaglebone black oscillate back and forth like a blue Cylon visor?

If not, It is possible that the eeprom has somehow corrupted the image on the ROV. You would then need to use an SD card, burn a flash image on it, and then apply it to the beaglebone by booting with the image and waiting for the lights to turn solid indicating a completed re-write of the eeprom.

If the lights are Cylon in nature, that indicated the ROV software has properly started up. In that case your back to verifying that your local adapter is properly hard coded to a 192.168.254.2 or higher address.

I’d start there and see which way the debugging goes. Good Luck!

-B


#4

Sorry for the late reply but I have been super busy and haven’t had much time to work on this.

Yeah the blue leds weren’t doing the visor thing so I burnt a sd card and that did the trick. Now the cockpit comes up :slight_smile: Only problem is without the SD card it doesn’t load. I tried doing the “Upload firmware from SD card to Arduino” thing but that didn’t work either. I guess I can just always keep the SD card in much having the eeprom work would be nice.

Anyway thanks for the help, I’m glad I could finally get it to work :slight_smile:


#5

I finally fixed the eeprom issue too! I wasn’t using the flash image just the normal one, when I tried with the flash one it worked! Now I can boot without a SD card. Thanks again for the help.


#6