[solved] cann't open the cockpit192.168.254.1:8080,How to do it?

solved
sos
software

#1

Hi everyone,

I‘m from China,a newer for openrov.

And now doing research on the underwater vision positioning. I purchased an assembled OpenRov in October。I did not do anything with it before I test it these days.I can just visit the website 192.168.254.1:8080 on the first time.Later I cann’t visit the page webpage any more.The Google Chrome show that the website was breakdown or the access is refused.

But I can visit the websites 192.168.254.1 or 192.168.254.1:3131 easily。I can also watch the video of webcam through the VLC media player by http://192.168.254.1:8090/?action=stream.

What can I do? Could you tell me in detail? Thanks

Solution: There was an error regarding xmpp in the error log indicating the google talk plugin was having trouble. Removing it allowed connection: [solved] cann't open the cockpit192.168.254.1:8080,How to do it?


#2

Hi hjm200891,

What is the status of the cockpit service when you go to the dashboard @ 192.168.254.1?

You can try stopping the cockpit service, waiting for 30 seconds, and then starting it again.

Can you ssh in to the ROV and send a copy of the logs? If you are on windows, you can use the Putty program to ssh on to the ROV. Let me know if you need more instruction.

Once you have a terminal ssh session, you can do the following to view the log

cat /var/log/openrov.log

Note, I am doing this from memory, and I think it is /var/log, but it could be /var/logs.

-Brian


#3

Thanks,when I go the the dashboard@192.168.254.1,the page just likes picture1.

And I tried stopping the cockpit service, waiting for 30 seconds, and then starting it again,the page likes picture2,it dosen't work.

when I sign in the ROV,using the command ‘ cat /var/log/openrov.log' or 'cat /var/logs' ,it display that 'No such file or derictory'.



40-picture1.PNG (145 KB) 41-picture2.PNG (38.8 KB) 42-picture3.PNG (101 KB)

#4

When using the cat /var/log/openrov.log' command, be sure to include a space after 'cat'

cat<SPACE>/var/log/openrov.log

It appears the space is missing in the screen shot


#5

sorry,I have used 'cat /var/log/openrov.log' this time ,and it appears in picture5.could you tell me what to do next?

38-picture5.PNG (235 KB)

#6

Okay. So we are almost there. The system is encountering an error when starting up. The problem is that the error has scrolled off of the screen in the screen shot. Putty should let you scroll back up and select all of the text. If you can do that and cut and paste all of the log it will help!


#7

thinks,here is the log,may it help .And the sreen picture is p1~p5

35-LOG.docx (14.7 KB) 36-p1.PNG (45.2 KB) 37-p2.PNG (44.6 KB)

#8

p3-p5

32-p3.PNG (57 KB) 33-p4.PNG (43.1 KB) 34-p5.PNG (49.7 KB)

#9

Thank, okay so I see the problem. A required library is "missing" on the filesystem. Assuming you have not changed anything manually, my best guess is that something became corrupt on the filesystem.

You can try a quick workaround by disabling the googletalk plugin which is failing to find a required library. You can do so by ssh'ing on to the rov and running the following command on pre 2.5 software:

sudo mv /opt/openrov/src/plugins/googletalk_ipregistration /opt/openrov

You can then restart the ROV. The system should work after that. If not, there may be wider corruption on the filesystem that requires a new image. The process requires that you have a SD card to burn an image on. You can follow the instructions on the bottom of the 2.7 ROV product page (it works for your model as well) http://www.openrov.com/products/2-7.html

Video example of removing the plugin on post 2.5 software:


#10

Thanks ,Happy New Year.

I use the command and it worked.


#11