[SOLVED] Can t connect to my openrov using chromebook


hi folks,
this is a nightmare :’( no idea what is going on, i can t connect to the rov using my chromebook, i can just ping it
here is the video

if i use another pc , no problem, any idea what is going on?
my chromebook is in developper mode

thxx for your time


Hi nocomp.

I would like to try and help. Please try and follow the link;

I had similar problems, but once I tried using automatic settings for the IP address I have not looked back. Occasionally I still have to ping Openrov.local but it is all settled. Brian Grau did a good job helping me.

I also operate a Chromebook with similar set up to yourself.

Good luck.


hi martin, you mean you can set ethernet in auto and the rov will deliver an ip?
you use http://openrov.local insteal of ???

thxx for your time


hi martin,

openrov.local gives me unknow host and i need to set manually the ip for ethernet connection otherwise i never get the "connected " status

i got this message from a chromebook board:

The 192.168.254.x segment is currently used for an internal bridge connection. That will go away with an upcoming version of ChromeOS.
For not, there is nothing you can do unless you can change the robots IP to a different subnet.

how can i change the ip of the rov?

thxx for your time


Hi again.
Just checked, my IP address is : "openrov.local:8080"
Once the system was set to Automatic this seemed to work. The only time I have had problems was as a poor topbox connection.
Hope it works for you.


changed ip to ad work like a charm.
you can t use 192.168.254.* on chromeOS, it s used for bridged connection by the os
i ll do a complete tutorial tomorrow

1 Like

Did you ever make a tutorial for using a Chromebook? Things seem a bit different for the Trident.
The IP of my Trident is, and poking around in the Chromebook, it seems like there’s a NAT layer, so I’m not actually on the 10.1.1.x network. Also, using Terminux, nslookup openrov.local doesn’t work.