[solved] Camera won't come on when powered through controller board

solved
camera

#1

Hi Charles,

Going to and closing Diagnostics window does fix the issue with some motors not going in the proper direction.

I do have the strangest thing where now my camera will not show video feed even though lights and servo work and all motors work.

The one time recently when I booted up and the camera did work, then the motors didn’t work. I hadn’t touched anything. Is this a software glitch?


[solved] Electronics: Controller not powering BBB or Comm board
#2

So close…I think.

Got a new BBB just to be sure. Can power BBB+webcam from my laptop (using USB) and see the camera in the dashboard.

Put the BBB onto the controller board and powerup with onboard power and control over the tether. I can control all of the motors and the lights, but the camera remains black.

All I can think of is that there is a combination of software and power that isn’t working (voltage across the batteries is 11.9V instead of 12, maybe that tells camera to disengage?)

Any one have this issue? So close to completion.


#3

Yep, the built in upgrade process if offline while we fix some problems with updates pulling packages that were still in development.

The USB power apparently goes down enough to cause the camera to reset during bootup off the controller board. Version 2.5.1-final of the software has a fix for that. In the meantime, you can work around by going to the dashboard (192.168.254.1), Choose services, and then stop the cockpit service, wait for it to stop, and then start it again. That will restart the camera as well.


#4

Thanks!
That work around resolves it for now.
Time to put her in the water!


#5