[SOLVED] Booting up openrov 2.8


#1

I finished today building our rov and was trying to connect him to my macbookpro but couldnt connect.

Any advise?
Wil post some pictures hopefully it is something simple


#2

Hi Richard. Well done for finishing it. Keep trying, it takes much longer to connect to the cockpit than you think. Sometimes a couple of minutes. Keep refreshing the browser.
Andrew


#3

How are you connecting the ethernet cable? If it’s a new Macbook Pro it won’t have an ethernet port. I use a Thunderbolt to ethernet adapter and it works nicely.


#4

I have a ethernet card. I got a 2009 model.


#5

The laptop see the rov. It says it is connected. When you connect the usb i can hear the rov starting up. After a while the leds start flashing. So it seems the electronics are working correct.

Does the imu has to do something with it. I havent used the flash card. Wanted to boot first at the original version.


#6

Still cant connect it. Tryed to Ping it. But no connection. 1 engine is tikking.
Have been trying to connect it almost 30 minutes.
I see multiple leds burning and flashing.

The last blueled is flashing and sometimes a second flashes too.


#7

Hey Richard,

well done with the built. It looks fantastic.

I would be very surprised if this issue due to the IMU.

Some things to try:

  • Can you connect to the Dashboard, which is located at 192.168.254.1?
  • Depending on the version of the Software, the ROV makes a noise when it begins to boot and after it finishes the boot sequence. For the latest release the ROV give a visual signal for finishing the boot, this signal is a double flash from the four main LEDs, does either of this happen?
  • This is my IP Setup, which looks slightly different (did you change the name of the connection to “openrov” or why does it not say ethernet?

And of course the next step would be to apply the latest image using this thread 30.0.3 software release notes

Hope this helps!


#8

@Fe3C i changed the name of the connection to openrov

And i cant load the cockpit. In Chrome i still get no connection.
The board is still running at his original software. I don’t know if i can upgrade it now to the latest version.


#9

Yes, if you choose to update, simply follow the guidance in the linked thread. It uses an microSD card to copy the new software.


#10

The update is from a microSD card so you can do it. The 30.0.3 can eliminate the need to set a static IP address which it sounds like might be the issue. It is also more stable and will hopefully solve your connection problems. The full release notes talk about the changes.


#11

@Fe3C, @Brian_Grau, ok Will try that tonight i got the update on a sd card. It was in the exlorerkit we bought in the storr


#12

Check the software version on the bag the microSD card came in. It might have 30.0.2 on the card not 30.0.3. The latest release is only 2 weeks old at this point.

You can always reformat the card and load 30.0.3 on it though.


#13

ok then it will be 30.0.2 it was delivered 2 weeks ago and shipped from the states to the netherlands.


#14

@e4andy @Fe3C @Brian_Grau thnx for your help i got the cockpit up and running.
won’t take long before my first dive with it


#15

Glad to hear that everything is up and running :slight_smile:


#16

#17

#18

This topic was automatically closed after 24 hours. New replies are no longer allowed.