[solved] Beaglebone novice help

solved
software

#1

Hello all & thanks to all contributors on this forum.

good afternoon all,
my name is stuart -located in scotland
i have recently purchased a half-built openrov via ebay and trying to pick up with it.

im confident enough with the physical build and the ‘electrical’ side of things,
but when it comes to programming etc i am a complete ignoramus so please excuse me!

since the item has been previously assembled to some degree i am not sure whats working and whats not.
so ive tried to first establish that the beaglebone is functioning with the openrov software.
(now, i dont know if the openrov software is already loaded on the beaglebone )

I can’t seem to make it boot from SD card anyway - have formatted 8gb card using SDFormatter and put image on using Roadkill Diskimage.
( image file OpenROV-2.5-29.img ) but if attempt to boot the BBB from the card i get 3x LEDS stay on, no other activity even after 10 mins or so.

WITHOUT SD card inserted, i can power up the BBB and it displays what i suspect is a normal pattern of LED’s , heartbeat etc.
my router lists beaglebone ip address as 192.168.1.4
& i can view the beaglebone user manual page on this ip address.
the bonescript example script ( blink 4 led’s ) works fine from this page.
& i can view the contents of the BBB drive via usb.
so the board seems to be working

i have managed to connect to “root” on the BBB using Putty, but not using openrov login details.

Does this sound right so far ?

i have failed to connect to the BBB on 192.168.254.1
can i tell if the openrov software is already loaded on the board or not ?

im puzzzled about the failed SD card loading - could it simply be the card? i’ve tried two different 8gb card SDHC class 4 and class X (10?) but both yield the same result.

ive read lots but i think im confusing myself further with things i dont really understand!
maybe i’ve missed a crucial step.

any insight much appreciated.

many thanks

stuart


#2

i should add that this is openrov 2.5B and windows 8
cheers


#3

Solved - very simply

By using Win32 disk imager software - as instructed in the openrov documentation.

hooray!


#4