[solved] 2.5.1 RC6 - motor config correction

solved
sos
software

#1

Hi everyone

After I now have updated to RC6 my motors are running incorrect.

Forward is = turning and visa verse.

I can not correct this in the diagnostics anymore :(


#2

Thanks for the update Tom,

When you existed the diagnostic screen, did you use the back button on the top or did you press [ESC]? That latter does not save the settings.

I’ll load the image up here in a few minutes and see if it happens to me as well.

Thanks again for the report.


#3

I used the back button


#4

Ah, this happened to me as well on the previous version of the software. While we are working to get to the bottom of this, try re-uploading the arduino firmware then power cycle then check the reverse box then power cycle.

This fixed it for me...whether or not that was a coincidence remains to be seen.

~Z


#5

Ah. Good call Zack. The Arduino firmware has to be reloaded to match the Cockpit software or this can happen.


#6

Ok…i’ll try to re-run the ''upload firmware ‘’ button in the cockpit?
How can I power cycle or restart the rov without pulling out the usb connection?


#7

That is the current way to power cycle the ROV, pull the USB connection.

Uploading the firmware will cycle everything that needs to be. You can also stop and restart the cockpit that is running on the ROV by going to the dashboard, choosing services, and stopping, wait, the starting the cockpit service.

You can "kick" the arduino by ssh'ing on to the rov and running

sudo /opt/openrov/cockpit/linux/reset.sh


#8

How do I kickass.to ssh and run sudo ?


#9

Damn auto correct. …hehe kick ssh’ing?


#10

Plus one on the issue - I am unable to change horizontal thruster direction as well and it also reverted to default non-reversed setting.

Where is the configuration saved and how is it stored/passed to the controller board?


#11

The flash version had this problem.
From sd card everything works


#12