Software Versions: No packages found after trying to upgrade to 30.0.0

sos
software

#1

Hi guys,

I screwed it up :cry:

I tried to upgrade to version 30.0.0 via SSH with my rov connected to my router.
The apt-get update went fine, but the install finished with this error:

The following packages have unmet dependencies:
 openrov-rov-suite : PreDepends: openrov-image-customization (>= 30.1.0~34.0aa5e90) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

After that I can connect to the rov, via cockipt and via ssh but I don’t get any response from it. No streaming, no motors, no light, no lasers. I tried to restart, reconnect, reboot, waiting…


I’ve seen a thread where two users encountered the same problem during the upgrade. I followed @badevguru instructions about stopping OpenROV proxy and connecting again to the router, checking that the ROV is connected to the internet, and I got the same error again and again. I also tried the “apt-get -f install” command but didn’t find any broken package.

Nothing seems to work. Any hint?


#2

I will help as soon as I get back to my computer. What image did you have originally? This may be something on our end as the stock images should not be able to see 30.1.x packages.


#3

Hi Brian
I had the 2.5.1-RC1 image.

-I could not fix it yet, but after trying to remember the steps I followed, I believe I did run “apt-get update & upgrade” and this was my mistake. If as you say the stock image isn’t able to see the 30.1.x packages, that could explain the “no packages found” message. It’s all upgraded but the image.

Is there any way to solve it?

-About the lack of dependencies/broken packages during installation, I have no clue…


#4

Okay. I think I follow what happened.

apt-get should be able to get you back to a stable image. Warning, part of my slow response is dealing with a service we were using for the web updates being down. As a result, you may have to stop the openrov-proxy and connect your ROV directly to the internet to perform any of these actions.

Ultimately, you want to install the Openrov-rov-suite package. It will take care of updating the rest of the packages that are grouped with that suite.

apt-get install openrov-rov-suite=30.0.0~99.06d0548

Now I am saying this from memory. apt-get typically prevents you from being able to “downgrade” versions of the applications. Since you ended up upgrading to pre-release versions (and I apologize that we shipped something that even made that possible), you may have to first uninstall all of the openrov packages first.

you can use dpkg --list | grep openrov to list all of the packages.

Of course the easiest way to fix this is to simply download the flash-image and return the image to the beaglebone. http://www.openrov.com/products/2-8.html