Software Plan Week of August 4th - 11th


#1

This is a weekly updates that gives a mini roadmap of planned development activity for the week. This is a bit of an experiment to see if it helps everyone get a better feel for activity that is happening in the code base, both internally and from the community.

This weeks high level goals for the cockpit and related software.

1. First prototype for including arduino code in the plugins package in branch [feature/plugin_arduino]

2. Rewrite the camera module to better support moving to a new camera in 2.7.

If you are working on some software, plugins, refactoring, etc... commenting to this post will help communicate to everyone else activity that is going on this week.

Useful links:

* Issue list: https://github.com/OpenROV/openrov-software/issues?state=open

And I will post updates to the thread as things get done or announced this week!


#2

#3

#4

Brian,

I know this sin't really a contribution, but more of a beta test of the daily images.

I installed the latest master image (#29), but I am unable to load the Cockpit (Port :8080) or the IDE (Port :3131).

I was able to load up the Dashboard, but I got an "Unknown" for the status. I tried hitting both Start buttons but got nothing. I tried the SD card with the image on a "bare bones" BBB only connected to the Ethernet and power and got the same thing. Any idea what's going on?



#5

Hey Kevin,

Glad you are trying them out. We had a DOA build last night. I need to reboot the server to clear the error. Bigger issue is that we don't have sufficient error detection to abort the build yet.

Short term, you can work around it by ssh'ing on the the rov, going to /opt/openrov/cockpit and doing 'sudo /opt/node/bin/npm install'. This will finish installing the serialport.io which is missing.

-Brian


#6

I have a similar issue. The dashboard starts saying unknown (which may be normal I guess) but then it says the cockpit (and cloud9) are stopped. However the cockpit is running.

I tried the work around (on the chance it would fix my issue) and, this is what came out:

rov@OpenROV:~$ cd /opt/openrov/cockpit
rov@OpenROV:/opt/openrov/cockpit$ sudo /opt/node/bin/npm install
[sudo] password for rov:
npm WARN package.json sync@0.2.2 No repository field.

> serialport@1.4.2 install /opt/openrov/cockpit/node_modules/serialport
> node-pre-gyp install --fallback-to-build

[serialport] Success: "/opt/openrov/cockpit/node_modules/serialport/build/serialport/v1.4.2/Release/node-v11-linux-arm/serialport.node" already installed
Run pass --build-from-source to compile

I then rebooted but nothing changed.


#7

Hm. Thanks for the report. I have the next build building and will verify the issue. It does look like dashboard is not pulling up the status of the servers correctly which is probably a separate issue.


#8

Working on the ability to install plugins from remote github repositories. Each author of a plugin gets to save it in their repo. Ideally we will be creating a plugins section of the forums where people can discuss the plugins. From the ROV cockpit you will be able to enumerate the plugins that are available on the internet and then 1 click to download and install in to the ROV. I am using bower (http://bower.io) as the main engine for handling packaging of the plugins.

The plugins will need to conform to the basic directory structure we have documented in git. The either the repo name or the title of the bower pacakge will name will need to start with "openrov-plugin-" to show up in the list.

The plugins will be downloaded to a folder outside of the cockpit project so that they survive updates to the base cockpit project.

The first release will require an internet connection from the ROV. I believe I can setup a simple http proxy via the browser to allow tunneling the bower traffic up through the socket.io connection with the browser in a future release.

Until we update the server side portion of plugin system to handle dynamic additions, the system may require a restart after the install in the first release.