ROV hangs and won't reconnect

solved
software

#1

Hello,

I'm a noob who just got my ROV working this past weekend. Very cool but of course there are a few glitches to work through. Hoping someone can help with these.

First some background: I'm working with Open ROV kit 2.6. Batteries are fully charged. I received the kit around July 15th so I *think* the latest firmware is already loaded and I should not need to load from a SD card or get new firmware from GitHub (which seems to be from Open ROV 2.5 anyway).

Problems:

  1. I've seen the "camera not working" problem multiple times. I've had it working on my test bench, but in my underwater tests it always seems to fail to show anything. This has nothing to do with the water, just murphy's law that when you want to use it you're out of luck. Anyway, I saw some posts from June giving various workarounds - like reloading firmware, stopping the cockpit and restarting, etc. Have the experts on this forum converged on the best solution to this problem?
  2. In trying to solve problem #1, I re-installed firmware. This worked on the testbench but when I used the ROV in the water the camera again was not working. I tried to re-install the firmware at that point and the installation seemed to fail. It started compiling but then seemed to hang there forever. I attempted to reboot the ROV by pulling the USB power cord from my computer but that did not seem to work. I was never able to connect to the ROV again from my (Chrome) browser. LEDs sortof look like they are going through the boot sequence but I can't really tell. I also tried to reboot by disconnecting the USB and one of the ROV battery packs but again, after booting I could still not connect. This is a problem because I can't re-install firmware if I can't connect through Chrome. What do I need to do in order to reset the ROV to be sure it will reboot correctly? If I cannot connect to the ROV via Chrome, is there another way to reset the ROV, or download firmware to it?
  3. My laser lights don't work. They work when plugged into the +/-5 volt socket and aligned them during assembly, but now that they are plugged into +/- P2 per instructions, they do not work. I have tried hitting a variety of keyboard keys including '/', '\', 'L', etc. No dice. Also tried measuring voltage across P2 as I do this but don't see any differential. Any ideas?

Thanks in advance for any assistance.

Jeff


#2

Re #2: Can you ssh to your ROV? If you can, it opens up a lot of troubleshooting steps. Make sure you have all the lights on the homeplug adapter on (as it can become unseated below the beaglebone sometimes).


#3

How do I establish an SSH connection? Do I just open a command prompt in Windows 8 and type SSH followed by the IP address?


#4

you can write the image to the sd card by taking it out of your rov and plugging it directly into your computer via a card reader port. If your rov does not have an SD card then you can buy one and write the image to it. then pop it into your rov and it will boot up with that version of the software. you will still need to upload the firm ware to the arduino though.

https://github.com/OpenROV/openrov-image

that link has the download of the image and how to write the image to the sd card.

Getting lasers to work requires you to change the AConfig.h file

SSH into the rov

type: sudo pico /opt/openrov/arduino/OpenROV/AConfig.h

you will need to type the password again.

there are a bunch of lines, look for the one that says lasers. make sure the brackets at the end of it have a 1 and not a 0. :)

click ctrl+x and save

you will have to re upload the firmware again so do this after writing the image to the SD card before uploading the firmware to arduino.

I don't know how to get the video to run properly. Is your computer reasonably powerful? or is it the old computer you are not worried about getting wet? :) I read some where that you can lower the video resolution if you are using a slower computer.

hope that helps


#5

Hey guys, thanks for the suggestions so far. They've been helpful.

Last night I decided to try booting the ROV again and this time it worked. This was with the electronics just sitting on my workbench (not encased in the clear PVC container). This time the ROV booted up. At that point I reloaded the firmware and again the ROV booted up and the camera was correctly showing a video image. Then I slid the electronics back into the clear PVC electronics container and put the caps on both ends. At this point I noticed that the video image was frozen and that the controls would not work. The ROV software was essentially hung.

It seems like there are a couple of possible causes. First, the white wires that run to the DB25 are just long enough to reach, so they are pulled taught when I put the boards inside the PVC tube. It is possible this causes some of the pins on the DB25 to touch together and short out some connections. The other possibility is that the board is flexing just a small amount when I put the whole thing inside the PVC tube, again causing some kind of hardware issue. Keep in mind that this all worked the day before, so I'm just speculating as to why it would have stopped working when I put the electronics back in the tube.

Anyway after that event I took the electronics back out and set them on the bench again. Tried to reboot a couple of times but no luck. Then downloaded new software per Darcy's suggestion and rebooted from the SD card. Still no luck. Downloaded Putty and attempted to connect via SSH but again no luck.

When I boot up the lights on the topside board seem to do the right thing and the lights on the arduino board also seem to do the right thing - although it's tough to know for sure. I thought there used to be a blue LED somewhere under the beagle board that would light up during the boot sequence and I don't see that anymore. If I let everything run for 5 minutes or so I notice the middle yellow light on the top side board goes out and the TPWR light on the arduino starts flashing 1 second on then 4 seconds off (repeatedly). So that's not right.

Are there diagnostics I can run to verify the hardware? Any suggestions??


#6

This problem has mostly been resolved. My BBB died and I replaced it with a new one. I've been able to connect to it via Chrome and also via SSH. There is still a problem whereby the latest ROV firmware will not bootup when loaded on an SD card, but I'm going to post that as a separate thread. Closing this one out.


#7