Problems with communications


#1

My 2.5 is assembled and my first test run... well lets just say it had it's ups and down.

Almost everything worked fine (for some reason the LED's weren't working yet they were before when I had tested it dry).

Anyway, my test we cut short because I started to see the main electronics tube starting to fill with water. I stopped right away and rescued the ROV. In the scramble, I knocked my tether off the chair and the home link adapter box broke.

I brought it home, dried everything out, put the home link back together and was reasonably confident I was going to be fine. Silly me.

Now, I cannot get the home links to communicate. The top adapter gets the 2 edge green lights, but no middle communication light. The E-Chasis home link adapter gets 1 green light and the main controller board has one green and one flashing orange light. The Beaglebone does not power up.

Here's what I checked so far:

1. At the DB-25, both battery packs are supplying 12.7 volts.

2. Without the batteries installed, I get 5V across C5 when plugged into the computer.

3. I get 5v from the tether wires on the DB-25

4. The BB powers up fine if I plug Bluetooth directly to it.

What am I missing?


#2

Hi Ryan:

I would try reseating/reinstalling your BeagleBone Black, or installing a new one if you have it. Also, after a flood, let the electronics dry out for a good long time, or put them in an oven set at a very low temperature (say, 180 deg F) to get it really dry.

Also, check the onboard +5V supply with a voltmeter. You can access it and ground on header J4 or J1.

So from your symptoms, here's what I think: the controller board and its 5V and 3.3V supplies seem to work. But the BBB is not powering up, so it does not connect via Ethernet to the Homeplug adapter. So, no ethernet light on the E-chassis adapter. Since the E-chassis adapter doesn't have a source of data, it doesn't connect to the topside. Thus, no middle light on either adapter.

Once you figure out why the BBB is not powering up, the other problems will likely go away.

-W


#3

Walt,

Thank you so much for your reply. I really appreciate your help!

As far as drying it out, my flood happened about 3 weeks ago so I feel good that it is fully dried out. I also took a dry tooth brush and gently scrub be both sides of the board to make sure any corrosion was wiped away and not bridging any circuits.

I measured the onboard power and some interesting results. When I measured the 3.3V supply, I read 2.89V - my multimeter seems to read a little low. When I measured the 5V connections, I'm only getting 2.9V. This was consistent across all of the J connections.

What does this mean?


#4

Hmmm. Well, it means either the 5V supply is broken, or something is loading it down so that it only puts out 2.9V.

Here's what to do next. Strip off the BBB and the homeplug adapter. Turn on the controller board by jumpering across J12; remeasure the 5V and 3.3V supply voltages. If they look good, add in only the homeplug adapter, turn the controller board on via the topside box, and measure again.

-W


#5

OK,

I followed your instructions, jumpered J12, and got 4.7V and 3.3V respectively. Installing the homepug adapter and powering from the topside, I get 2.7V and 2.64V respectively.

I also tried measuring with the homeplug installed but powered via the J12 jumper. This way I get 2.84V and 2.78V.

This is all done without the BBB.

Does this mean my homeplug is shot?


#6

No, the homeplug adapter is probably good. There's an issue with the controller board before that- either the 5V supply is bad, or there's something loading it down excessively.

Debugging this gets a little tricky here. You need to figure out which issue it is- defective supply or parasitic load.

Take the homeplug adapter back off, and this time disconnect the 3 ESCs and the tilt servo from the servo output connector (J8?), taking particular note whether you have one or all plugged in backwards. Power up the board via J12, measure to see if the 5V supply is still only 4.7V, and feel around the board to see if anything is getting hot. If you have an ammeter that can handle up to 1 Amp or so, remove the batteries from one pack, place the ammeter in series with the batteries from the second pack, and measure the current draw from the batteries with the board turned on. I'm guessing that the power supply and the arduino should only consume 50-100 mA. If there's a short somewhere in the 5V supply rail, it will be drawing something like 800 mA from the batteries.

-W


#7

I tried the step one of the debug and I'm actually getting 4.64V tonight with the ESC's and tilt servo unplugged from D6-D8 and D11 respectively.

I have to admit the ammeter is a bit beyond me so I'll have to take this into the engineer at the office and have him check that with his equipment in the morning. Thanks again!

PS: I didn't notice anything getting warm while it was powered up.


#8

Work got busy and it took a while to get the readings.

When the circuit is completed with the multimeter, I immediately get a reading for 40 mA for a fraction of a second and then it jumps up to 170 mA.

Do I have to replace the board? I'm assuming the new board would be v 2.6. What else would I have to switch out to be compatible with the version?


#9

Hi Ryan:

The currents look OK- it looks like the 5V supply provides just enough power to start the Arduino, which after a fraction of a second turns on the ESCs, which raises the battery current draw.

So there doesn't seem to be a parasitic load on the 5V supply. I have no idea why it's not working. If you're good friends with the engineer at work, you might want to bring in the board and its schematic (you can find the schematics on GitHub), and try to figure out what's going on. The 5V power supply is on Page 4 of the schematic.

The biggest hassle with switching over to a new control board is that you're going to have to move all the ESCs over, and if you buy a 2.6 board you will have to make some small connector changes for your current homeplug adapter to fit. You could E-mail David to see if he has any old 2.5 controller boards left in stock.

Also, you might want to consider updating your endcaps to the 2.6 design. It's much more robust against water leaks. There is an upgrade kit available in the store here.

-W