Problem with laser lights


#1

Hi,

Booted up the ROV the other day, and have been tinkering with it. Mounted the laser lights in P2- and P2+ next to the LED's

However, I cannot get them to work. Tested them seperately on a battery, and they work fine.

I suspect this may have something to do with keyboard layout, since the key for swithching the lights is "\" which is not in the same location on a Norwegian keyboard compared to US layout.

I tried to switch to US layout and used the key that should have been correct according to US layout with no success. The key should be situated 3rd to the right of "M" correct?

My suspicion is strenthened by the fact that the key for the HUD display only toggles on/off when I choose US keyboard.

Or am I missing something, does it have to be enabled somewhere else, in software for example?

Any help is appreciated.


#2

You can test the keycode here:

http://www.asquare.net/javascript/tests/KeyCode.html

The software is looking for the particular value of 219.

https://github.com/OpenROV/openrov-software/blob/master/src/plugins/rovpilot/public/js/rovpilot.js#L257


#3

Thanks for the tip Brian, appreciate it. Have not had the opportunity to test it out yet on the laptop in use, found the appropriate key on my stationary here, so will definitively check it out once I get the chance. Will let you know if it worked.


#4

Got the lasers working, used "L" and it worked fine.

Embarrassingly enough that's what the popup text in ROV cockpit says, or "l" L in italic, which I wrongly interpreted as /, or forward slash.

For the record,

I'm not very familiar with programming, but it strike me a bit odd that in the "rovpilot.js" the letters presumably indicating which key to press don't correspond with the keycode according to the link you sent me

For example:

//i (laser lights)

KEYS[219] = {

"i" is actually keycode 73, whereas "\" is keycode 219 according to the link you sent me. ( at least on this stationary PC.)

Actually, this got me a bit suspicious, so I tested the JavaScript Event Code Test Page in parallel both in IE and Firefox, and oddly enough I sometimes get different keycode whilst pressing the same letter. For instance:

FF: "\" gives code 220

IE: "\" gives code 219

FF: "-" gives code 173

IE: "-" gives code 189

It also changes depending on which keyboard language I'm using, at least for the special characters like ,.-'ยจ\

But anyway, lasers are mounted and working great! That's what matters.

Thanks for the help!