Problem with camera after update/changes


#1

I've completed and been doing testing on the 2.6 ROV. I had a problem with the camera which was fixed with clicking "zero depth" or "calibrate compass", then I updated the system and found that it no longer worked with the addition of the beta options of "water type". Since then it was intermittent that the camera would work, it would some times work if I rebooted the cockpit a few times, though most of the time the image would be just black, and not the circle with a strike.

I found with water testing that the waterproofing of the motors was an issue, and ended up cutting them off to reseal them. While it was off I was trying to do some further testing, but the camera will absolutely not work now. I removed the beagle bone and connected it directly to my laptop and the camera works, so I went through and cleaned all the connections and rechecked and while it's connected to the rest of the ROV I can't get it to work. Any pointers?


#2

Hi Pspar,

The camera is hosted using mjpegstreamer. Go ahead and SSH in to the beaglebone. You should be able to confirm that the camera is by checking to make sure /dev/video0 exists:

"ls /dev/video0"

Assuming the beaglebone is recognizing the camera, you can manually restart the mjpegstreamer process by restarting the openrov cockpit. You can do that from either the dashboard (http://192.168.254.1) or via ssh by

"sudo /etc/init.d/openrov restart"

Let me know if that helps. Short term we are in the process of a refactor that helps with the stability.

-Brian


#3

I've tried rebooting many times to no avail via dashboard, but I"ll try to SSH in and restart the streamer Using only the beagle bone connected via patch cable and usb directly works just fine so I think the problem is located within the arduino card. I am going to solder the motors back in tomorrow and hopefully figure out the camera issue afterward.


#4

Hey Paul,

Did restarting the camera manually workaround work for you?

-Brian


#5

Unfortunately no, I had to do a complete reflash. After doing that it's been fine.