Pro HD-Camera doesn't work


#1

Hi, I bought pro HD-Cam in OpenROV store.

So, I tried to upgrade my cam in OpenROV 2.8v

I followed assembly manual for Upgrading pro HD-cam

After Finishing that, I connected cockpit with SD card(30.1.0 #169) in Beaglebone black.

But the result was that mentioned picture.

And also I reinstalled 31 ver image burned SD card in BBB.

I saw same display. I checked connection wire, chip etc about HW.

I think that HW parts doesn’t have any problem.

I tried to solve this problem by searching in Forum. I couldn’t get any solutions.

Please read & reply my topic

Thanks Regard


HD Camera Not Operational
#2

Me too. I have no camera feed with my HD camera. I am using the SD card which came with the kit and I assume a 31 image. Also the lights flash on and off quite soon after booting up.


#3

I gave up the hope that there will be even better firmware for the OpenRov.
I do not see any changes in the Github for months.
The last RelaseCandidate firmware now already one year old.
It is probably only developed for the Trident.
All customers like me bought the HD Camera update will have to live with the unfinished firmware.


#4

Recently, I reinstalled images in BBB & SD card. I confirmed that problem solved. Display status is normal.
I didn’t know the cause of this problem. I guess that cause is instability of 31 ver image.
I recommend using past version image(30 ver etc). In my opinion, Pro HD-camera is friendly in trident system.

By trial and error, I got know-how about solving this problem. If you have this problem, you reinstall images repeatly until you don’t have this error. I’m so sorry for this answer.

Then I pray for Success of RoV’s Operation. Thanks regards


#5

https://docs.google.com/document/d/11Z2jdTLRgehW_KRjDDBIb5kdB-526KkmfgKleUeB_3Y/mobilebasic

Zack from Openrov sent me the above and solved the camera issue.

To get the latest software running try this. Leave the sd card in while running, formatted with latest image 31.**. You may have to format the sd card a couple times to get it right. Also, try firing it up and unplugging it a few times before opening the browser the first time but after burning the new image. rov.openrov.net will be the address to pull up the cockpit. I have not been able to get the wireless tether setup to run on image 31 but it works great once you get it going plugged directly into the ROV. Once the cockpit loads, give it time, and keep your internet connected the first run. Set your computer to automatically get the ip. When everything has had time to load, go into the setting for the camera and change GOP length to 1 and your video should appear. In the future, if you lose camera fed, change the GOP to 1. Also, make sure your browser is in desktop mode, go full screen, then adjust down from there to get all your info on the screen.

Hope this helps, I felt your pain.


#6

Sorry for the delay guys.

Just to respond to the thread, we ultimately had some camera’s floating around that had firmware that needed to be corrected. The primary failure symptom is that the 2 our of 3 times, when starting the cockpit software, you would get a black screen.

Support has been handling these cases with step by step directions to fix the issue.

Generally, if you have this symptom, you can verify if the firmware needs to be corrected by ssh’ing in to the ROV, then as sudo run mxcam bootmode. If the result is snor, then it needs the correction.


#7

Can you repost this with more detailed instructions? What is [quote=“badevguru, post:6, topic:5988”]
ssh’ing in to the ROV, then as sudo run mxcam bootmode. If the result is snor, then it needs the correction.
[/quote]

I don’t know is that is typos or geekspeak for something I don’t understand.

Thanks from all of us mechanical but not computer programmer types!


#8

Start at step 5 in the link I posted above is what he is saying.


#9

THANKS! Makes sense now.


#10

Hi, I’d like to say that my issue is resolved and I have fine video now. The problem I now see was that I had not gone through updating the software. The guide is here and if like me you are not updating the normal camera, but building your ROV from the Pro bundle, it is not immediately obvious you need to do this.

Anyway I did it and it all works. Great!