Port Motor and Servo Malfunction


#1

Howdy all, I recently completed a 2.5 build. For the most part it functions properly including the lights, camera, starboard, and vertical motors, but the port motor doesn't function at all. When I first tried to calibrate the ESCs, the port would not beep but rather trigger a twitch in the motor in place of the beeps. I thought this might mean that the port ESC was bad, so I replaced it. It now beeps and doesn't cause the twitches, but still doesn't calibrate or operate the motor.

Also, the servo is constantly engaged when the ESCs are in the "on" position. The servo is torqued all the way to the top and continues trying to raise, so I've had it unplugged while trying to troubleshoot the motor issues. At some point I'll need to fix this as well though.

I am on the 2.5 Beta 2 software, by the way. Any and all help/suggestions would be greatly appreciated. Thanks!


#2

Hi Brad:

If the servo is constantly trying to push past the mechanical range of the camera tilt platform, then the servo horn is likely not positioned correctly on the servo. See the first part of Step #65 on the Dozuki guide for OROV 2.5.

As for the motor and ESC, I would start by using an ohmmeter to check whether any of the three motor wires are open or shorted. I don't know whether this will work with the ESC in place- it's unfortunate you didn't do this when you had the ESC off for replacement. Anyway, with the ROV power off, try to take a resistance measurement between each of the pairs of motor leads --> A-B, A-C, and B-C. They should all be roughly the same, with no short circuits or open circuits. Note that the winding resistance is small (~0.2 ohms), so you need an ohmmeter that can resolve this.

You also might want to look in the ESC documentation or on the internet to decipher what the beeps you're hearing mean- that might give you the answer directly.

-W


#3

Thanks for the Reply, Walt. Indeed, I had neglected to center the servo horn during installation.

As to the port motor, it's actually quite embarrassing... after installing the new ESC, I had forgotten to plug it into the board. After doing that, all is functional, so it must be that I had received a faulty ESC the first go round.

Can't wait to get this puppy in the water this week!