Photo capture questions re release 2.5-RC2


#1

Hi ,

I can capture the photos now but what can I do with them?

Can I delete them from the cockpit? If not how?

Can I save them to a laptop file easily or should I be using VLC instead?

How much memory is available for the photos?


#2

While I work on a screen cast to show how to manage the photos, let me leave you with these quick tips:

1. Once you capture photo's, they display in the photos tab. You can click on them to retrieve an individual photo.

2. One Cockpit version 2.5+, the easiest way to manage the photo's is to connect to the file share available on the ROV and copy or delete them from there. The directory that stores the photos is /var/www/openrov/photos. To get to the file share option, just go to the http://<ip address of rov. No port number, and you will get the dashboard. At the bottom you have to "start" the file sharing services. Once started you can simply browse to //192.168.254.1/var/www/openrov/photos to access the file share of photos.

3. If you are using an SD card to run the OpenROV image, the space for photos is limited to size of the SD card. If you have 2.6 ROV that is running the image off of the built in EEPROM, you probably have about 300MB of the 2G EEPROM space available for photos.


#3

Txs

With sharing running , I tried to browse chrome to //192.168.254/var/www/openrov/photos and I get an err message: cannot GET/var/www/openrov/photos



Is there some type Of permission required?



I can get to the photos with putty ok.



Chris


#4

Sorry. Use file explorer in windows. It should prompt you for the openrov credentials.


#5

Hmmm explorer converts it to
Http//192.168.254.1/var/www/openrov/photos
With error. Web page cannot be found.


#6

Sorry. Windows and names. "File Explorer". Not IE.


#7

Win 7 converts the address typed into file explorer search input to an http: prefix. I didn’t use IE. I tried to keep it from doing that by typing directly to address window and entering. I think I was successful once and got a "file not found error. It did not query for rov credentials. Has anyone with win 7 verrfied this works?


#8

Ah. Turn around the slash's: \\192.168.254.1\OpenROV\var\www\openrov\photos


#9

Ok I get into rov but dir only has
arduino
dashboard
etc
gui
linux
node_modules
src

Cannot get to var dir

What now?


#10

Woops. Sorry for the delay!

Turns out the defaults on the image changed since I looked at this. To get it to drop you on the root folder you have to change the configuration for samba which is easy:

1) SSH on to the ROV

2) sudo pico /etc/samba/smb.con

3) At the bottom of the file are the setting for OpenROV. Change the 'path" from '/opt/openrov' to '/'

[OpenROV]
comment = OpenROV Cockpit
path = /opt/openrov
force user = rov
force group = admin
read only = No
guest ok = Yes

4) No go to the dashboard and start the file sharing service

5) Connect to the file share, you should now be able to walk through all of the folders including the one containing photos.

On the next update, we will be sure to add that access to the photo directory back in to the default configuration.

Thanks!


#11

Hi, I am new to openrov,

When I ssh the rov, and I do a ls, no folders exist. The file smb.con does not appear. Only hiden files can be found .extension.

Thanks for the help


#12

Some time has passed since this thread was started. I believe the later release of v30.0.03 would have followed, which I have installed. I am also running windows 10 but do not see an easy option for managing the photos. Is it possible for someone to put an up-to-date sequence of instructions, aimed at a level to suit the not so software orientated builders and operators, to follow on this thread , or in the operating manual.
Much appreciated. Thank you.


#13

We are working on a more streamlined solution for this to allow to save and delete pictures from cockpit.

For now the easiest way is:

  1. Take pictures through cockpit.

  2. Open the photos tab.

  3. Click on each picture to open in a new tab.

  4. Right click on the picture and “save as” to save it to your local disk.

  5. Once all the pictures have been saved locally then you will need to SSH into the ROV in order to delete the pictures. If you are running 30.0.3 open the IP address 192.168.254.1:3009. User: rov Password: OpenROV. Then type: sudo rm -rf /var/www/openrov/photos This will delete all the pictures on the ROV.

I hope this helps and if you want to track this issue, here is the link.


#14

Thanks Brian.
That keeps the thread nice and simple. You’re a gem.

Incidentally, my first wet trial/photo session at a model submarine event produced some impressive results. No problems.


#15

No problem! I am glad I was able to help.

Do you have any pictures you are able to share?


#16

I’m on my phone at the moment. When I get back to my computer I’ll send some.

Looks like a GoPro will be my next investment… …then the trident! Need to talk nicely to my bank manager, indoors. :grin:


#18

A few photos from my first wet trial dive.


#19

Great pictures! Thank you for sharing!