OpenROV Controller Board Rev2.6


#1

Greetings all from Vancouver Island.

Happy New Year 2015.

Been watching the progress of this OPENROV project for some time.

Early last year (2014)started to gather parts for a winter project build.

Bought most parts separate however purchased the Controller Board V2.6 from OPENROV Store.

Early last year could not purchase a BBB anywhere for love nor money. Finally purchased one in Vancouver and took delivery in the summer.

Started to assembly mid December 2014.

I am cautious, knowing that sm components can be easily blown by static and/or mishandling.

I assemble components then test before going to the next stage.

Sequence so far;

Received BBB and loaded the image on sd via desktop, and placed in BBB, connected camera and powered up via usb into my desk top Win7 computer.

Went through BBB website and loaded drives (64bit) and displayed the Cockpit, works fine and repeats.

Disassembled the Tenda adapters (V1), powered both up using voltage regulator, wired a tether between them and tested to see if I could get communication between my router and laptop.

After getting the IP address correct, things worked fine.

Then I connected the BBB with the camera to one of the Tenda Adapters and connected the tether, then connected to the surface Tenda adapter then to laptop. Worked fine, laptop displayed cockpit with image from camera. So far so good!

Next stage to put Tenda Adapter on the Controller Board. Made modifications to the Board so as to accommodate the V1 adapter. Also at this stage soldered the 3 esc in place.

Wired the tether into 18 & 19 on J5 and connected 12v power supply to 4&7 grounds and 5&6/ 12volts.

Switched the surface adapter on , measured voltage at 18&19 on J5, 4.73volts.

On the controller board LED 1 green & LED2red came on. (So the tether voltage switches the power on the controller board.)

Checked voltages on J9 and J10, where the Tenda Adapter plugs in.(without adapter plugged in at this point)

Voltage on J9 4.98volts

voltage on J10 4.73volts.

I then switched off the surface adapter, thus powering down the controller board, plugged in the adapter board and switched the surface adapter on.

Led 1green came on, & Led 2red though dim at first came on the bright, no lights on the Tenda adapter board.

Measured the voltages again on J9 & J10...this is where I am flummoxed

J10 reads 4.73volts (great)

J9 the voltage has dropped down to 1.23 to 1.27.....what is going on???

Has any one else experienced this?

if so what is the solution

No BBB mounted at this time, waiting till I remedy the adapter voltages on J9 before I continue.


#2

How are you powering your setup? The system needs a momentary 1.5A+ to startup with everything assembled.


#3

Hi Brian,

Thanks for your response.

I have tried various 12v DC power supplies ranging from 4 to 10 amp output with no success, connecting between ground 4&7 and 5&6 +12volts.

The voltage on J9 before any boards are mounted on the Controller board is around 5.0 volts after plugging in both Tenda Adapter and BBB the voltage on J9 drops to about 1.25+/-, and the BBB does not power up(no blue lights).

Any trouble shooting suggestions to check and track voltages on controller board?

(I have a sinking feeling that the controller board is kaput)


#4

Hi Shaughan:

The voltage that you measure on J9 is puzzling. If you pull the schematic of the controller board off of GitHub, you'll see that the power on J9 is supposed to be 3.3V, not 5V. The homeplug board wants 3.3V, and I suspect that feeding it 5V has now damaged it. But the interesting question is, why is there 5V on J9 to begin with?

If you look at sheet 4 of the schematic, you'll see that regulator U5 takes the 5V supply and drops it down to 3.3V- this is supposed to be what gets fed to J9. Can you check the output of this regulator and see what's going on with that? Please do this with the homeplug adapter not mounted.

Maybe you have a bad regulator, though the board test procedure that is done on the 2.6 controller boards at the factory is supposed to catch this. Do you have anything else wired into the 3.3V bus (like stuff on the I2C lines, or anything?

-Walt


#5

Hello to Vancouver Island,

i have the Tenda 200 V1.1 and it was not easy disassemble the two Board.

I must desold it and got a little damage.

Now i must build a Connection to the 2.6 Board.

How did you does this ?

Greetings from Germany


#6

Hi Henk:

See this blog post from last year. The "old" adapter referred to in the post is the Tenda V1.1 adapter.

Also, there is no need to desolder the two V1.1 boards to get them apart. You can just carefully cut them, as is shown in this blog post.

-Walt


#7

Hi Walt,

Thanks for your response,

The only thing that I have attached on the board are the 3 ESC and they are not plugged in yet

I switched on the ROV controller board by applying the voltage to the tether from surface tenda adapter..

No BBB or adapter board on the controller board.

Checked the voltage at J9 again, was +4.98volts DC

Checked U5 regulator .

The voltage Vin reading was +5.03volts DC ref to ground.

The voltage Vout reading was +4.98volts DC ref to ground.

Also checked C15 voltage was +5.03Volts DC ref to ground.

Looks like your hypothesis of a failed U5 was correct, well done.

What would you suggest to remedy?

Is the board covered under any warranty?

I have powered up the tenda adapter that was on the controller board with a 3.3v dc supply, and it powers up.

Checked it for functionality , unable to get communication with topside adapter.

Looks like the ROV adapter is possibly fried.

shaughan


#8

Hi Shaughan:

If the 3.3V was defective from the factory, I imagine we'd replace it. I'd start by sending an email to support@openrov.com (I think that's the right address), and reference this thread.

-W


#9

Easiest way to contact support it so use the link on the main support menu option:



#10

Hi Walt,

Thanks for your reply.

I will contact Support regarding the defective Controller Board for a replacement (either 2.6 or possibly new 2.7).

As the Controller Board also "fried" the subsurface Tenda P200, I will be needing a new replacement Tenda Adapter kit.

I noticed, while searching, that there is a Tenda 1000mbps kit available.

Have you taken a look at this model?

If you have, could it be used in OPENROV?

Has it the same "footprint" and could it just "plug in" the P200 J9 & J10 control board sockets or would a new controller board design be required? (Ditto for surface?)

I have concerns that my BBB might have been fried as well. But it powers up and am able to see the Cockpit on my desktop. I have not tested it for other functionality as yet. Any comments?

Best regards

Shaughan

Ps. I have been in the background reading many of the ROVers concerns and replies that you at OPENROV have provided. I must say that I am very impressed with the helpfulness and shared knowledge from both sides.


#11

Hi,

I have repaired the V1.1Board and changed the 2.6 controller board.


Now it fits perfect. An LED on the V1.1 lights for 5 minutes and then starts to flash.

I think this is normal?


The 2nd V1.1 I have changed so accurately and easily change the topside interface.


The last thing I need to produce to the BBB to connect to the Tenda the network cable.


Greeting Henk