OpenRov controlled though iPad via portable AP - works


#1

Hey there,

a few posts mention that control through a Tablet/Phone might work with a portable AP, but nobody seems to have tried it and written about it.

After I keep tripping over the wires and almost killed my laptop I tried it with a TL-MR3040 portable AP and it works great. The AP has an in-built battery which powers the topside box and network lag seems acceptable with 90 to 260ms. Will try it at the lake later this week and hopefully at sea on the weekend.

Parts list:

- PELI 1450 case for everything
- PELI 1050 case for topside box and AP
- TP-Link TL-MR3040 portable AP (comes with network cable and USB cable)
- iPad 3
- 2x Scotch resticable silicone mounting tabs for sticking the iPad to the lid

This makes for a very nice control station! Interestingly no video feed on Chrome on iOS, but everything works great in Safari.

cheers, Axel

806-20140217173241__DSC4917.jpg (465 KB) 807-20140217173157__DSC4914.jpg (447 KB) 808-20140217173210__DSC4916.jpg (318 KB)

#2

This looks awesome! What are you using to control the ROV then?


#3

Just the iPad. The standard OpenROV cockpit has touch controls in the gui for movement, lights, camera, and laser. Really awesome. The controls for forward/backwards/left/right are a little hard to spot though.

Works great on Safari for iPad. Chrome and Firefox don't work (no video).


#4

If you connect a Bluetooth keyboard to the ipad will it work like the computer? One disadvantage, can't record video via the iPad interface.


#5

Extremely cool! Thank you for posting the parts list too!


#6

Using VLC you should be able to use any computer,
connected to the same sub-net, to take care of the recording... ;-)


#7

Cool solution Alex. This is exactly what I am looking for to eliminate the wires. We plan to use the ROV on Alguita ORV and the main complaint from the skipper was the amount of wires. A few questions:

Q1: What kind of tranmission range have you noticed?

Q2: What is the charging time for the router?

Q3 Have you thought about a way to connect up a wireless gamepad to work with the IPAD?:

This configuration would also allow the topside connector and tether to be placed on a float to possibly extend the range without increasing the length of the tether. A possible use might be to attach the float to a ghost net to keep the rov monitoring aquatic dwellers in the net. The rov pilot boat could be free to drift without having to adjust the tether for that movement. Having adequate router range is essential for this to work.


#8

Hi Chris,

wow, Alguita sounds very interesting. To be honest I haven't done a lot with the rover because another project popped up and I'm busy until June. I just played with it for a few minutes at home after changing the configuration.

Q1: don't know really, only used it up to 2m.

Q2: It's a big battery with 2Ah. So 2h at 1Amp, 24h at 500mA.

Q3: It seems the cockpit user interface detects when a mobile browser is connected and switches to touch controls and Keyboard input doesn't work anymore. I assume it's the same with a gamepad that's connected through bluetooth, so some code will have to be changed. Would be nice though, I'll probably look into that when I get back to working on/with the openROV.

I put the router and topside connector in a little peli case, but I would be reluctant to float it out. I don't think it would help with the range.

cheers, Axel


#9

Have you tested the robot in deeper waters with the iPad?


#10

Hi Axel,

I bought the stuff and the wireless works great but the top side adapter doesn't power up when plugged into the USB port.... unless the charging port is also connected.

From what I can see, you didn't have this problem. My unit is a TL-MR3040 V2. The only thing I have modified is upgrading the firmware to the most recent version. The one that came with it was a 10/17/2012 version. Did you change the firmware? Any ideas why mine is different?

Chris


#11

Ok... mystery solved. This was a tough one but it turns out it was a faulty USB power supply. A hairline fracture in a trace that connected the USB mini B ground to the internal circuit of the USB power supply. Turns out that it worked when plugged into a loptop or when the wireless router had its charger plugged in because the shield ground provided the ground for the powersupply. The TL-MR3040 when operating in battery mode doesn't connect ground to the shield. I fixed it by resoldering the trace and now it works. Thanks again to Alex for coming up with the configuration.

The diagnosis was tricky... first I thought it was something in the TL-MR3040 but I measured 5 v on pin 1 and 4 of its usb. So then I thought there might be a current limiter so I cut a USB cord and put a resistive load to verify that the port could supply enough current to the USB powersupply. That checked ok...tested it to .5 amps.

I then poked around inside the USB power supply and noticed a transient with pressure around the ground connection of the mini socket. I also got a clue when I plugged in the TL-MR3040 charging cable and shorted its free end ground to the plug shield and the USB powersupply started up.

Note to Eric and David:

I believe the failure was a result of constant wiggling of the USB mini socket on the USB board when the plug pulled in and out. It is a fragile connection since the socket is not fastened securly to the topside box frame. This is a design weakness in my opinion and should be corrected in new iterations.


#12

Axel,

Since you can connect to the IPAD I thought it should work for the Iphone. I cannot get safari to bring up the openrov 192.168.254.1:8080 web page. The wireless router connects ok but not sure what I have to do to connect after that. I tried setting the static IP address to 192.168.254.2 and sub mask 255.255.255.0 with no success. Is it possible that my ATT network is blocking 8080?

Have you tried connecting to iphone?


#13

DIR-506L from D-Link works too. ;) It was $29.99 on Amazon.ca

With a quarter, to show size. The TPlink router beside it doesn't have a battery, but is very small. I may fasten it to my kayak and use a battery pack to power both homeplug and router. that way I can leave it set up and remove just the battery for charging.

Ports


#14

This would work well for launching from my mini motorboat.


#15

You have likely already solved this issue, but the ip address you use when using a router would be determined by the router (instead of 192.168.254.1). Just log into the router and check the list of clients to see which ip address is assigned to the OpenROV.


#16

I sorted out my 'other' question (had to restart the iPad to log back in to the wireless router), now trying to figure out how to 'drive' with it. The up/down works fine, lights, lasers... Do I need to enable a different controller? I don't seem to have forward/backward/left/right. I tried tilting the iPad with my thumb on the cross sliding in the direction i want to go thinking maybe it was like an AR Drone, tried sliding my thumb on the cross when level, etc... it shows that its getting input but no motor activation.


#17

Hi,

yeah, from what I remember the user interface is not working perfectly on the iPad. Sorry I don't remember any details, I haven't used the openROV since March.

Had limited success in fresh water, but no success in salt water. I'm quite excited about the openrov as a proof-of-concept, but found it not suitable for anything useful to me.

kind regards, Axel


#18

AH, thank you!!!! That is super helpful, as I'll stop beating my head against my iPad now :) On the bright side, having the router actually makes things quite convenient when piloting on beach.