OpenROV board troubleshooting


#1

I'm so close to the end...

During testing last night, things seemed to being working well for about 2 minutes but I suddenly lost all power. Didn't think too much about it because I was on the same battery charge from my first power up. I took the batteries out and topped them off and tried again tonight.

I had taken the E-Chasis out because I needed to recalibrate the ESC's (fixed - thanks Mathew!). With the e-Chasis out, everything seemed to be working fine. Video, LED's, motors, etc. So I put the main tube back together again and that's were my problem is.

Everything powers up, I get 3 green lights on the topside adapter, 3 green lights on the E-Chasis home link adapter, blue lights on the BB, but I cannot reach the cockpit now.

Looking at the lights, I see a green power light on the OpenROV board, but the only other light is a flashing yellow light at the other end of the string (I included a photo). Is this my problem? Thoughts on causes?

Thanks,

Ryan

891-IMG_0680copy.jpg (320 KB)

#2

I had something similar happen to me. My ROV randomly died then I couldn’t connect. After days of trouble shooting I ended up finding out I was somehow frying the sad cards. So I redownloaded all of the software and got a new SD card. It still don’t know what caused it. I only “fixed” it.

Best,

Cannon


#3

In the interest of helping anyone else with a problem like mine...

Inspired by Cannon's suggestions, I started to work on the SD card angle. Before going through all the re-imaging, I tried the easy stuff first.

I just popped the SD card out and back in again. So far, problem solved!