OpenROV 2.8 refusing to shutdown then no longer powers up

sos

#1

Hi all,

I’m new to the OpenROV forums. I recently built an OpenROV 2.8 which worked fine after building it and I was able to take on several dives. It began behaving strangely after unplugging the electronics from the end cap and replacing them, wiping down the acrylic tube and sealing everything up.

I connected the ROV to my laptop to test if all was well before taking it on a dive. I heard the typical power up beep and the lights and lasers were flashing, but found that the cockpit & dashboard would not load.After much refreshing, resetting my network settings and restarting the topside box it still would not work. I unplugged the topside box usb and ethernet cables from my computer, and strangely the ROV did not power down, the lights kept flashing, the LEDS on the control board and beaglebone were still illuminated.

I waited for over 10 minutes and the ROV still had not powered down, so I unplugged and replaced the batteries. I reconnected the ROV and again encountered the same problem, cockpit would not load and ROV would not shutdown when unplugged. I replaced the batteries a second time, but when I plugged in the ROV a third time it refused to power on.

I removed the electronics from the electronics tube, cleaned everything with a dry cloth and replaced them. I noticed a very small amount of condensate on electronic boards. When I plugged the ROV into my computer it again refused to turn on. I then decided to test the beaglebone alone. I tried powering it up via usb and found that it did not power up at all. All LEDs remained off.

Does this sound like I need a new beaglebone? Could any of the other electronic boards be affected?

Thanks in advance for any assistance.


#2

Did you end up getting this resolved through support?