Openrov 2.6 startup


#1

Hi all
I acquired my Openrov 2.6, 2 weeks ago. I’ve enjoyed assembling with not too many problems so far. I powered it up for the first time today. Looked very impressive, lights flashing etc but I have no idea if it’s working the way it should. The instructions said the software is already installed but I suspect I will still have to do some installs on my computer or maybe on the units itself. Could someone please advise me on this. Also is there a download for the control panel?

On a different subject I noticed different people have experimented with a rear fin. How well have these worked?


#2

The only thing you need on your computer is a web browser. Chrome seems to work best, though some people use Firefox. If you're going to use a gamepad controller, I would recommend Chrome.

-W


#3

Thanks Walt

A few more questions

  1. Is the software already installed the latest version or do I have to update?

  2. Do I need a current “Openrov image” or will the browser do this?

  3. How do I identify the static IP address or should I be able to access at 192.168.1:8080

  4. Do I have to set my static IP address for my LAN port

I noticed a problem with the topside adapter. The Ethernet connection extended quite a bit which didn’t allow the pins to be pushed fully together. This made this connection intermittent. I think I have solved this now and have all three LED lighting up.

Thanks again


#4

Hey Dave,

To answer a few of your questions:

  1. Yep! For 2.6 kits, the beaglebone already has the software you need flashed onto the memory. It has something pretty close to the latest version, but some other improvements and bug fixes are being developed right now. In a month or two, I’d recommend checking in to see where it’s at, but what you gave should be fine.

2.You won’t need to download any software images. You cqn just log in with chrome, ans Cockpit will come up.

3.The default static IP of the ROV is always 192.168.254.1:8080

  1. To log in to the ROV directly, you’ll need your computer’s LAN terminal to be set to a static IP in the subnet of 192.168.254.x. where “x” is any number that is less then 255 and not 1. I usually set my LAN to 192.168.254.2 and make sure my subnet mask is 255.255.255.0.

The issue with the header height on the topside adapter is a known problem which we’re going to fix in the next batch, but (as you’ve found) as long as the boards are pushed together the right amount, what you have should work okay.

Reguarding your question in the last post about fins (like the one Cannon created), I haven’t tried that out myself yet, but it seems like a great idea- it should allow your ROV to track in a straight line better and will keep the ROV from pitching so much during vertical maneuvers.

Please let us know how the rest of your build goes- we’re excited to see the ROV come to life!

Eric


#5

Dear Sir,

I have got v 2.6 last three weeks and assembly well with first start without any update software, before we put all in place with glue , there are some mistake with cockpit dislay in right hand window said, 'log pilot setup complete' and I cant do anymore , keyborad key nnot response , I ask to Brain help me to download new software run on SD cards , everyting comeback with all telemetry data but cannot read depth that require me to calibrate in SSH, So. i go to putty to try to log in with rov and password OpenROV , it require rov password again , What is second password, i try with OpenROV but not success, so i type with after next one 'sudo pico/opt/openrov/arduino/OpenROV/AConfig.h', command not found,

until now, I cant calibrate ESC motor success yet, even I concentrate following to instruction , anytime when i switch on ESC , motor start spinning by himself ,

Please kindly help,

Thanks /Kosit