Open ROV 2.6v cockpit startup

sos

#1

When opening the cockpit, we are experiencing difficulties. When the camera is not working, the motors will run. When the motors run, the camera will not work. We have to close, stop, and refresh the cockpit multiple times to get both components to work. Is there any suggestions to fix this problem?


#2

Hello,

Have you done any software updates from when you originally received your ROV?

If you have not updated your software:

When cockpit is open click not the Diagnostics tab, click the zero depth, and then the left arrow next to the word Diagnostics to exit the menu. Wait a few seconds and the video should appear. (I know this process sounds really weird but it works)

If you have updated your software:

If the camera does not load you can restart cockpit which will also restart the video process. This can be done by logging into Dashboard (192.168.254.1) and then clicking "stop" under cockpit and then wait a few seconds and then clicking "start." Give the ROV about 30-60 seconds to boot up cockpit and then when you go to cockpit (192.168.254.1:8080) the video should be working.

Please let me know if these do not work.

-Brian G.


#3

Hey Brian,

Thanks for your answer to the solution, I was also struggling with the similar situation.

I am still struggling with motors. I was wondering if we need to calibrate motors each time we upload firmware to Arduino.

Thanks and Regards,

Pratap


#4

Hey Pratap,

I’m working on an issue with the inbrowser update process that has been causing problems with the motors. I recommend you upgrade using the SD card method as noted at the bottom of the 2.7 support product page (and yes, the update works for all BeagleBoneBlack + Controllerboard ROVs) for now until the following issue is fixed:

https://github.com/OpenROV/openrov-software/issues/338


#5

Thanks Brian,
I really appreciate your response.
I tried that image. However I am not sure why but the motors, though calibrated correctly, are not responding to the commands from keyboard. Also I don’t see any ‘cmd go()’ in command logs which I used to see in the right hand side log list.

Please let me know if this problem is trivial.

Thanks and regards,
Pratap


#6

Pratap, did you go to settings and upload the Arduino firmware after installing the new image?


#7

Brian, yeah I do Install firmware after installing new image


#8

Are any of the keyboard commands working? Also you can try the diagnostics screen and use the motor sliders, do they work?


#9

Hey Brian,
None of the keyboard command is working however when I go to diagnostics screen and use the motor slider. I think I am able to calibrate the motors however moving the sliders does not trigger the motors.


#10

Also, do you have a command to upload firmware from rov login in the updated image. For instance this command “sudo /opt/openrov/linux/arduino/firmware-installfromsource.sh” used to work on old image but does not work anymore on new image.

Thanks and regards,
Pratap


#11

Has changed to
sudo /opt/openrov/cockpit/linux/arduino.firmware-installfromsource.sh

If everything is working right and you have put the motor in calibration mode using the button on the ESC, then the motor will not run during the calibration process. Checkout this post from Ray who goes over this in detail: ESC Programming and Calibration

Okay, If I understood correctly, you are having trouble getting any keyboard commands to work? So for instance, if you press the P key to turn on the lights on the main cockpit screen, nothing happens?


#12

The software update did not help our situation. We are now having trouble with the cockpit crashing randomly. We have started another discussion for this issue. We are beginning to wonder if it just a buggy software? We had problems with not only one OpenROV, but four. Two from kits, and two hybrid systems with bilge pump motors. Do you guys have any more suggestions?


#13

I have the problem,too. And I also try different version flashing into the BBB, But all failed. The Original Version in OpenROV 2.6 can control the device, but the video always disappear, I have to restart many times, after i upload OpenROV-flash-2.5-30, Or OpenROV-flash-2.5-29, i can’t control anything about the ROV.

I didn’t but a IMU depth sensor, after I upload firmware. I can’t control anything. What should I do for that.

It shows that

log pilot setup complete.

mpu init failed with code-6

Depth Sensor intialized 12C.

Could I sent back the partial product to fixed it. I live in Taiwan. My e-mail: b00408028@ntu.edu.tw

Thanks,
Jimmy W.


#14

Jimmy, go ahead and use this one http://bit.ly/openrovimage2-5-1

It is the final version of 2.5.1 for running off an SD card.


#15

Hi
I still can’t solve the problem, It shows the
log pilot setup complete.
mpu init failed with code-6
Depth Sensor intialized 12C.

I have upload the new firmware and software. nothing workout. and the video shows only one second.

current branch: stable
2.5.1.30.448f366

Thanks,
Jimmy,W


#16

Hey Brian,
Thanks for your response, I think the issue was arising when I connected the IMU. Because everything was working fine before it and I suspect that the arduino code waits for I2C response and gets stuck there.


#17

Hmm. The 2.5.1 image has protection to prevent lockups from the IMU from blocking anything else.


#18

Oh, I am using 2.5.1 only, If it has protection to prevent lockups, then I cannot figure out what could be the possible reason for my case


#19

Can you confirm that after loading the 2.5.1 software that you went to sethings and uploaded the matching firmware to the Arduino as well?

Did disconnecting the IMU resolve the problem?


#20

Hey Brian,
Since it was not working that time. I shifted my focus to make the ROV work autonomously and was performing some task like stablising at a particular depth heading in a particular direction (I used a diffferent I2C based IMU for this as the one which come with the kit has issue with magnetometer). I was doing this using Arduino IDE and with an external programmer.

I will connect everything soon and will burn 2.5.1 again and will let you know if disconnecting IMU resolves the problem