One engine is all time running


#1

Hello openROV Community

*yeah* I have finished my openrov. I got a great TCP/IP connection. camera is up and running

Light on and off works fine but with the motors I have a problem

They don't do what I am try to tell them ;-)

One engine starts when I connect the USB cable.

It is possible to use the up, down, left & right keys but with "space" it is not possible to stop the engines

Should I change the 3 EZRUN 18V ESC ? or could it be a software problem ?

Thank you for your help and feedback


#2

Hi Juergen
Have you programmed the ESC?
http://wiki.openrov.com/index.php/Programming_the_ESC


#3

Hello Armand

Yes, the ESC are programmed and controlled with the program card - LED ProgCard EZrun

kind regards

Juergen


#4

Ok, just had to check the obvious. I had to do it twice, could not get it to work the first time, when I checked the settings the second time, some of them had gone back to default settings.

I take it you also calibrated them since programming is only the first step.

If the motors make a "beeping" noise when you apply power, then something is wrong with the settings. Motorbrake is on or something.

If this is done correctly, then it could have something to do with the trim settings.

http://wiki.openrov.com/index.php/Software_Manual#Throttle_and_dive

I have never got this to work properly, if I touch the key 7-9, then the motors start going and will not stop even if I press space, which is supposed to reset the trim settings. I have to reset the browser to make it stop. If you check the manual motor settings in the ROV Cockpit the settings should be 1500 for all 3 motors and they should be still. Don't know if this helps you, but it's the best I can come up with. Maybe someone else has a better idea.


#5

Hi Juergen

You did not mention that you had calibrated the ESC's yet, that would be the next step. This is done through the cockpit as per the instructions
http://wiki.openrov.com/index.php/Programming_the_ESC

this could be the issue with motors not stopping.


#6

Hello David

Thank you for your feedack.

I have calibrated the ESCĀ“s.

I used the LED ProgCard from Hobbywing to be sure
and there is still the problem

kind regards

Juergen


#7

I have the same problem, vertical thruster is running as soon as I plug in the usb cable...I have gone through the programming twice... please help