No video


#1

I just completed my OpenROV build, and the mandatory bathtub test. Except for breaking one laser, and a leakage that had to be fixed, everything went surprisingly smooth...

Today, I planned for a real-world test in a local lake (Stodalsvatnet, Etne, Norway). At home, after plugging batteries, and connecting my browser to see everything worked, I had no video signal. All motors and lights were working just fine, but a totally black video. Looking for a solution, I found one suggestion to hit the Zero Level button, and one to reload the Arduino firmware. The last one did it (I thought), so I shut down and went for the lake.

Now, after connecting again, I had no video. Everything else Works just fine. After troubleshooting for a long time, several Arduino updates, and a lot of reboots, nothing seemed to help. From earlier, I've seen that video can be streamed from port 8090, so I tried a simple telnet to this port. No response on that port... At last, I went to the main dashboard page (served on http://192.168.254.1:80) and found I could stop and restart the "control center" service. (Can't remember the name of the service, but the top-most). Doing this caused the video to show up, but everything else stopped. I am not sure what went wrong here, but it just seemed to ignore any command from my keyboard. After playing around, stopping and starting this service a bunch of times, I end up getting both kayboard/motors and the video working.

After getting home, I get this error all the time (no video). Stopping and starting this service from the main dashboard page does the trick, but it often needs to be done several times and in combination with restarting the browser (Chrome).

Does this sound familiar to anyone? Is there a solution, or any tip for where I should start troubleshooting? I was also looking to find if there is a separate video service (deamon) that I could restart from a SSH session. Is there?

Regards,

Roar


#2

This seems a bit odd, but some tests here might indicate a poor Connection in my port battery tube was the fault. I thought I read somewhere the two batteries are Connected in parallell, so it doesn't make much sense. Anyways, several tests with a disconnected port battery shows the symptoms of no video, while I have a good connection, the video shows right away.

Does this make any sense at all? If the two batteries are truly parallell connected, could it be that a part of the circuit is very voltage sensitive, and being fed by a single battery just isn't enough?

I'd appreciate any feedback on this. Trying to understand things bit-by-bit :)

Regards,

Roar


#3

I have experienced this several times before. The best working solution for me is to disconnect both batteries before connecting them again.


#4

Hi Roar,

If there are any issues which cause the USB port not to respond, the MJPG Streamer process can give up which is why nothing will be listening on port 8090. Restarting the cockpit process from the dashboard ends up kicking off the mjpeg streamer process again which is why your video then starts. There is a command line option as well if you ssh in to the rov:

mjpg_streamer -i "/usr/local/lib/input_uvc.so -d /dev/video0 -r 1280x720 -f 10" -o "/usr/local/lib/output_http.so -p 8090" &

-Brian


#5

Thanks a lot!

This greatly helps when troubleshooting :)

Just out of curiosity, are such processes well-documented, and I just failed to find it?

Regards,

Roar