No Response To Controls


#1

So here's the issue I've run into, hopefully someone can point me in the correct direction....

I've got the unit (v2.5) connected via the tether, and can see the cockpit screen in Chrome, including the camera showing whatever it's pointed at. But that's where the responsiveness ends -no control over the motors, lights, camera servo. In the past I was able to work all the features when directly connected to the BB (not via tether), now that I have it connected via the tether it's not responsive. I've double-checked all the wires, and I've reloaded the software, batteries are charged - still no response. When I tried connecting directly again, now it does not respond that way either.

Any suggestions?

Thanks,

Todd


#2

The first thing I would do is clear the Browser cache or try a different version of Chrome.

Just a sanity check but make sure the ESC switches are in the on position.

Try Installing jumpers on the control board to power up the ROV. J12 & J17

although it seems that it is powering up ok via the tether this is likely not going to help but worth a try.

connect a patch cable to the BBB directly to your system and set the ip address which seems that you have done as you have video. This is just to bypass any tether issues which I don't think you have.

If the cockpit comes up with Video then we know that the tether is working and the control card was powered up via the tether. We know that the link adapters are working. So it comes back to why you have no control. Possibly Browser issues is my guess.


#3

Thanks for the suggestions- tried them all, and no change in the status. Tried installing chrome again, latest version has no response. Also tried in Firefox, no difference there either.

Any more ideas?


#4

Sounds like the code hasn't been loaded onto the arduino correctly... You should be able to do this through settings(?)in the cockpit. you just need to browse to the arduino code and load it on.


#5

Success - strange, since it had already been loaded correctly, but it works now - thanks for the suggestions!

Next up is finally getting it in the water - looking forward to seeing it in action!

Thanks,

Todd