No Motors with Keyboard...only works in diagnostics


#1
We have voltage and camera view...no motors! I did the upload firmware to Arduino update but this did not fix the issue. We can get the motors to run within diagnostic menu but not with the keyboard.
I have attached a screenshot of the cockpit...
Any suggestions would be much appreciated :)

#2

Hi Ashley

I Just noticed your posting here on the Blog after I responded to your direct query.

You mentioned here that you have motor control via the Diagnostics which tells us that the Arduino & ESC's are working ok.

1. Make sure you are using US English Keyboard settings on the laptop.

2. You can also try another laptop or desktop to make sure this is not an issue with your laptop.

3. Does the Compass, Pitch or Yaw change if you move the ROV around.


#3

I am using US English, have not tried another laptop but I could track one down.

Compass, Pitch and Yaw do not change when I move ROV...meaning?


#4

This is kinda odd then if you can move the motors in the Diagnostic panel but not with the keyboard.

are you able to turn lights up and down?

are you able to tilt the Camera?


#5

Not able to move camera, no lights or lasers either?


#6

Ok if you are still able to move the motors using the diagnostics, and I suspect that you are doing this by using the mouse? I think you should also be able to use the keyboard do that while in diagnostics mode as well.. please confirm this.

Maybe another member can also confirm this as I do not have an OpenROV to test it.

Please also try using another PC & Google Chrome to control the ROV which should eliminate the suspected keyboard issue.

IF the above has been tried and things still do not work it would be worth while to burn a new image to an SDcard and insert it into the BBB. This image will take priority over the flash on the BBB. I would also then upload the Arduino code again making sure there is no errors.