New Release Candidate Image ready with 31.0.0 RC

release-notice

#21

geoffryash, I tought about it, but don’t know how to do it in x-mode. In direct-mode the profile can be set up as you wish. If anyone know how to do this in x-mode on an Logitech F710, please let me know… (edited, mixed up x-mode/direct mode first time…)


#22

Uploaded the new Release Candidate version of the ROV image: http://bit.ly/orov-image-31_0_0-RC4

Key feature changes to be aware of:

  • Default keyboard and gamepad mappings have changed, you can go to the [input] applet and change to the “classic” preset if you want the old controls back. New controls are listed in the [input] applet, but essentially they are game controls (AWSD) + EC for up and down. Gamepad puts the forward on left stick, yaw and lift on the right. I am acknowledging that for the 2.x series ROVs we probably need to move lift to the left stick…

Lots of bug fixes in this one including

  • improvements to the keyboard/gamepad mapping including saving of custom settings
  • default theme UI tweaks
  • video recording management fixes
  • reenabled depth and heading hold
  • video of the HD pro coming up reliably

#23

These can now be inverted when configuring the gamepad axis in the [input] applet.


#24

Initially there was a patch we had to apply for the dev software. Is this fixed in this image, or do we have to run the patch again after installing the new image?


#25

To my knowledge, no patches are needed. This has all of the changes we are aware of and works on both the stock and HD Pro camera ROVs. If you run in to something be sure to let me know!


#26

Have installed, and tested the new version “on the table”. And you guys have done a great job!! Thanks! My thruster issue is solved :slight_smile: Now it’s ready for test dive, so my ROV is going to be wet this weekend :slight_smile: But a new bug turned up, when I choose mobile ui, the “new ui” is still showing up, so I can’t get it to show the mobile_ui. This was ok in the previous version. And I still don’t get any video on playback of the recordings, so I’ll use screencastify for now.

And a question:
Is the “fly by wire” function supposed to be working, or only the normal heading/depth hold?

I’ll get back to you with a report after diving :slight_smile:


#27

I’m assuming you are using the HD Pro camera? If so, it may take up to 5 seconds or so for the video to start playing using the replay feature. Also, at the moment you do have to refresh the browser after doing the recording so that it shows the video segments as being available for download before the replay will pull the video.


#28

Nice Job! Everything seems fine.
When I start the ROV, after a minute or so it resets itself a couple times in sequence, flashing the internal lights once each time.
Is that by design?
Only other thing I would like is the ability to persist the geomux settings. They still reset each time.
Sweet! ready for my first dive!


#29

Hi Brian,
What is the rationale behind changing the function of the keyboard keys in RC4 compared to the original function of the keyboard keys?
Regards,
TCIII AVD


#30

Yesterday I did a test dive with HD Pro camera, and the 31.0.0 RC version. It went quite well, here are some comments:

  1. Mapping of the gamepad was great, could set it up just as I wanted to, including decrease/increase of motor power. You guys did a great job there.
  2. Get some lags in the video, tried to get video smoother with decreasing Framerate, GOP and Bandwith, but could not get it smooth, at least with the settings I tried. Any other good tip regarding this?
  3. Finally made the replay to work. But how to sync the video? I’m online, and logged on, but the sync button is grey. Need to know how to download/extract the video.
  4. Doesnt seems like “fly by wire” is working. Ticket it in setup, but ROV is acting as normal when I let the controls go. Any way to make this function work?
  5. Video quality was greatly impoved with the new camera :slight_smile:
  6. The switching between gyro/compass is still unstable, works only one or two times, then it get stuck in gyro.
  7. When using ex. an ipad in addition to the computer connected to ROV, what is the best way to stream the video directly to the ipad/iphone etc?

A video from the testdive, recorded with screencastify. Actually found a old car I haven’t noticed before. Quality got a bit decreased during video editing. Using HD video converter factory for converting the video to mp4, then Movie Maker for editing. Any good tips for converting/editing for best possible quality of the finished video?


#31

Hi @TCIII,

The decision behind changing the default mappings for the keyboard and gamepad was fueled by the developers’ experience with the video game industry. The mappings that are the new defaults more or less reflect the standard way video games are mapped. Our rationale was that with the upcoming release of Trident (and continued usage of the 2.x series) we wanted to give our new ROV users an experience that they might already be familiar with.

With that being said, we are definitely open to input from the community to tune these default mappings to maximize the flying experience. For example, auxiliary button mappings, such as LED toggle and servo tilt, are a hotly debated topic here at the office and we are still not sure if we have found the optimal configuration. If you, or any other community members have any ideas, please let us know!

Finally, if you really like the classic OpenROV mapping, we still have that preset available for you! Just navigate to the Input Applet (Top left hand corner->Inputs), click Load Preset (near the bottom of the page), select the loaded presets dropdown, and click OpenROV Classic. Now, whenever you boot up the ROV, you will have the Classic OpenROV mapping that you are used to.

Thanks for your input! Happy exploring,
Gilbert


#32

@gilbert,
Thank you for the explanation, much appreciated.
Regards,
TCIII AVD


#33

If you have not tried this already, try setting the GOP=1 and let me know if that improves the situation.

Sync will be enabled as soon as we get the server side setup in a production environment.

Thanks for the report!

Ipad/Iphone support is still being baked at the moment.


#34

No, that is an issue we are currently tracking: https://github.com/OpenROV/openrov-software/issues/627


#35

Thanks for your replay, much appreciated! :slight_smile: Today I started to struggle with another issue. I had a leak the other day (nothing to do with this), but after fixing it, I vacuumed it to test it, and powered up the ROV, to generate some heat before inserting the plunge, as recommended. Then I couldn’t get any video or ROV data using the rov.openrov.net adress. Restarted laptop, and ROV several times, no action at all! Tried using the IP adress, then I gor ROV data, but no video. Was using wifi, so I tried with ethernet cable, just the same! Was a bit frustrating, since I didn’t do any changes to my laptop, or the ROV software. Just as an attempt, I ran CCleaner, and cleaned up the laptop, including chrome’s catche. Then suddenly it worked as it should, using rov.openrov.net, both on cable and wifi. And also the video suddenly seems to be smoother, with less, actually none stuttering…testing it on the table. Ready for another testdive :slight_smile: What is the connection here?


#36

Hi Rune

I have similar problems about a year ago with my OpenRov 2.8

And this answer from Nima at support solved my problem:

“Do you have a Tenda, or Power Over Ethernet device in your house? Or are you working next to a router? If so, either disconnect the Tenda / POE device from the wall, and work away from the router. The issue might be Radio Frequency interference. The tether is unshielded wire, and is susceptible to radio interference. If you have Tenda-like devices in the walls, the power from your computer (if it is plugged in) will also have a datastream embedded in the voltage you are using from it…”


#37

Thanks for the tip, erhanse, but I’m afraid that’s not the case here. I don’t have such devices, and the only thing solved it was cleaning up the cache. Have never seen this before, and suppose it have to do with the 31.0.0 RC version. Might be because I had some recordings from the ROV, that is stored in the chrome’s cache. I really don’t know, but I’ll “keep an eye on it”, and see if it’s repeatable.


#38

Hi Rune

Take a look at this video from my dive with the OpenRov 2.8 last december in Larviksfjord

I use the Debut Professional by NCH Software to capture the PC screen,
and the Video Professional also by NCH Software to edit the video and export to mp4
See http://www.nchsoftware.com/capture/index.html
and http://www.nchsoftware.com/videopad/index.html

I am happy with the quality


#39

VideoPad Professional is the correct name of the editor software


#40

Hi Erland!

Thanks for the tip! The video looks good, but seems like you got a lot of stuttering? Actually a lot more than I had on mine. Do you know the reason for this? And how did you get the old HUD on this new software? I’l try the NCH, but won’t the home edition work just as good? I’s a bit cheaper than the pro/master vesions…

Rune