New Release Candidate Image ready with 31.0.0 RC

Quick question, have you tried to burn this 31 into internal eMMC? I’m looking information about how to flash any 31 RC version in the internal memory. Standard BBB procedure using S2 button (USER) at power-up sequence won’t work.
Thanks in advance

Hi All,

When communicating with my OROV2.8 equipped with the Pro Camera HD-Upgrade I was running Windows 7 on my laptop and was able to communicate with the 31.0.0 RC4 OROV Cockpit firmware using and get good video. I was hooked up directly to the Ethernet bridge and had the IPV4 connection set for DHCP per the instructions above.

I have upgraded my laptop to Windows 10 and can no longer communicate with the 31.0.0 RC4 OROV Cockpit firmware using with the IPV4 connection set for DHCP. If I now use I get the ngnix server message. If I use I am able to access the OROV cockpit, but get no video.

Since I moved to Windows 10 on my laptop, should I be using a different means of establishing communication with the OROV other than which as I stated before no longer works?

Update: I decided to try using a fixed IP of for my laptop, like with the stock OROV2.8, and then used to communicate with the OROV Cockpit instead of 192.168254.1:8080 like with the stock OROV2.8. Fortunately for me this solution worked and I got good video though I had to adjust the GOP to 10 from 90 to keep the display from locking up.


Hi All,

While poking around on the Trident Support Forum I found out that OROV has limited the real-time video coming up the tether to 720p to reduce lag and bandwidth requirements. Later the actual 1080p video, which is stored on board the Trident, can be down loaded for a higher quality image playback.

My question now is if the OROV2.8 Pro Camera-HD Upgrade video coming up the tether is 1080p, but uses H2.64 compression, why do we have to reduce the camera bandwidth and GOP to get a video stream that does not lock up? I suspect that it might be my older HP laptop cannot handle the decompression of the H2,64 compressed video without reducing the bandwidth and the GOP?

Therefore, is anyone using an Intel I5 or better equipped laptop with an OROV2.8 equipped with the Pro Camera-HD Upgrade to view the camera video with the default Bandwidth and GOP settings without getting freezing or lockups?

It would be nice if the Cockpit firmware could be modified to send up either 720p or 1080p depending on the needs of the user.


1 Like

Hi all,

I do a fork of openrov-cockpit and openrov-software-arduino to bring this 31.0.0 alive and bugfree.
You could checkout them out here and
I resolved only two bugs who annoy me. The depth lock now works (@guillaume.ethier) and rov gamepad api is compliant with newer versions of chrome.

How to use it, Just download the 31.0.0-rc4 file apply it to the mmc card and update the files with my repositories (warning on openrov-cockpit you must checkout the v31.0.0-rc branch). I could make a new image of this if some of you are interested.

1 Like


Nice work.

A new image would be best as installing the new Cockpit version would be a one step process.


I have done a new image with my changes here.

Changes are :
Gamepad now works with recent chrome
depth lock work as expected
a new ssl certificate (This one is generated by me not by a trusted certification authority, so you still have one error on first connection).

PS: I don’t have tested this image as I don’t have the ROV before the end of the week, I hope I don’t make any mistake. Test it or wait until next week.



Nice work and I am sure that it will be aptly appreciated by all of the OROV2.x users!



The last OROV2.8 release was 31.0.0-rc4.

Is there a reason your OROV2.8 update release is 31.0.0-rc7?


Openrov team already tagged 31.0.0-rc5 and 31.0.0-rc6 on git but never released an image file.

I just do +1 on release candidate version.


Hello everyone,

To tell you that I just tested the image I recently provided for users of openrov2.x and it works well. This image is launched from sd card and doesn’t touch the bbb memory at all. So test it !
Stay tuned because I have something bigger that will come in the near future.



Hi i was unable to use my ROV s , since gamepad stop working, RC7 , by michael.bouchaud, put me in the Game again,

1 Like

I have installed the rc7 version but now when I try to connect to the rov it just sits on the “Connecting to ROV” screen.
Am I doing something wrong or are there other steps than just burning the image to the SD card and turning it on?

Which browser did you use ? firefox or chrome (chromium)…

Hi Michael,
I used the latest version of chrome available

Hum this is strange…
I could recommend a new test.
Plug the rov and let it to start, wait for the led goes on. (if the leds are blinking, something goes wrong).
When the led are on, launch chrome and try to open the webpage of the rov.
Wait and see…

Okay, I’ll give that a go tomorrow and post back

Thanks @michael.bouchaud.

I can report RC7 is working fine for me on an OROV 2.8 with HD cam and using Chrome 32 bit v77.0.3865.90 (which Chrome reports as being the latest official release).

Using INPUT config I was also able to map some additional commands which had no preset value.

I was previously using RC4 without the gamepad / F310.

Your work is much appreciated. I will stay tuned for the “near future” announcement !

Hi Michael,
Okay, so I plugged it in and waited for a while. The main LED’s flash and dont stop.
Is there some way to determine the error causing this?

@Sharky Do you have an hd camera or the stock one ? I tested once with the stock camera but all people who report this image works fine, have the hd one. Maybe this is the issue and it could be fixed.
Another thing could be the communication between the arduino and the bbb board, you could try to reflash the arduino firmware.


I have the stock camera. Wish I had the HD one but as they are not available anymore I’m stuck with this. Also dont have the IMU/Depth module :frowning:
Guess the camera could be the issue then

Thanks for your help