New Release Candidate Image ready with 31.0.0 RC

release-notice

#1

We are preparing for the 31 release of the OpenROV Software Image. There have been over a year of updates since the last major release. Given there are a lot of breaking changes since the last release, we have bumped the major version number for the release to 31.

I have just uploaded a the latest revision for the image file.
http://bit.ly/orov-image-31_0_0-RC4
http://bit.ly/orov-devimage-31_0-2016-12-07
http://bit.ly/orov-devimage-31_0-2016-11-12

PreReqs:

  • Recent version of google Chrome on either desktop or Android.

File any bug or issues in [github][1].

The Dev Image is intended to run from the SD card. There are several sets of instructions for burning the .img file to a SD card. You can find tips and help for burning image files to the SD card here: https://forum.openrov.com/search?q=burn%20image

Major feature changes since 30.0.3 release

  • New default UI theme for desktop and mobile
  • Mobile/tablet controls rewritten
  • http://rov.openrov.net works off-line after first use so that you can review data after a dive
  • Records h.264 stream from the HD Camera Pro upgrade without a plugin
  • Other users can connect to the same ROV and are put in a peer-2-peer network for efficient sharing of video and telemetry
  • Default video to 30fps 1280x720 for MJPEG video
  • Removed the Dashboard and replaced it with in-cockpit navigation to applets for changing settings, viewing telemetry, and many more.
  • Automatically upgrades micro-controller firmware to match the cockpit software when upgraded (removed the old upload firmware button)
  • Support for super low-latency video using the HD Pro Upgrade camera
  • Data Applet for downloading and managing recorded dives. Supports replaying saved dives in the browser. (Video replay requires the HD Pro Upgrade camera)
  • Changed the url used to connect to the ROV along with moving the connection to https
  • Hovering over recording icon of telemetry and video shows remaining disk space
  • Added Gyro mode as default IMU compass mode. This is more forgiving when the compass in mounted in an area effected by lots of magnetic fields on the ROV. You can switch back to standard compass mode in the UI.
  • Added control for a single external light to be controlled from the cockpit
  • Keyboard and Gamepad can be remapped
  • You can switch from Imperial to Metric and back again by clicking the unit under depth on the default UI
  • New data management applet for managing recordings of telemetry (and video if using the HD Pro camera)

Feature Notes

  • After connecting to https://rov.openrov.net, be sure to bookmark the site, and on mobile to add the site to your home screen so that Chrome will preserve all of your data recordings even when your drive is running out of space.

##Technical Changes:

  • Moved to Node6.x
  • Kernel Version Upgraded
  • New UI for cockpit set by default
  • Lots of performance improvments
  • Dialed in most of the new-ui desktop theme
  • The APIs for the the micro controller and the socket.io API have breaking changes
  • Rework of the I2C libraries for better handling of the IMU

To load cockpit: https://rov.openrov.net/
To load cloud9: http://rov.openrov.net:3131
To ssh: https://rov.openrov.net/wetty

Tips:
The web ssh tool, wetty, uses Shift-Ctr-V for paste on windows, and standard Crt-C for copy. OS X uses its standard keys.

Known Errants:

  • All issues for the current dev-image can be found here: https://github.com/OpenROV/openrov-software/labels/module%3Adevimage
  • The proxy service has been disabled for the moment while fixing an instability that just appeared with the node 6 upgrade. This only prevents you from accessing downloadable plugins.
  • The default mobile theme context menu does not scroll
    * The ROV cylon lights are disabled in this image pending a performance fix
  • IOS not currently supported
    * Gamepad does not remap correctly. PR in progress.
  • Link to OpenROV Cloud services via your forums login
  • The https://rov.openrov.net does not resolve if you plug the ROV directly in to a router. In that case you must get the locally assigned IP address of the ROV and edit the host file on the computer you use to connect to the ROV so that rov.openrov.net points to the ROV. While you can connect to https://<rov ip address directly, the cert will be invalid and some features in cockpit will no longer work correctly.

New Developer Image ready with 30.1.0
IMUV2.0 problems
No camera feed or light toggle after connecting gamepad and adjusting input map
BBB won't take update
No camera feed or light toggle after connecting gamepad and adjusting input map
Problems updating to 31.0.0
Help desperately needed - a bad day!
[SOLVED] New 2.8 build-- Starboard Battery Tube replacement and nearterm bypass
#2

I have posted an updated beta for the next release. http://bit.ly/orov-devimage-31_0-2016-12-07

Small performance tweaks
Fixed the HD Camera not displaying video
Fixed gamepad remapping
Other small tweaks


#3

Hi! I have installed the 31.0.0 version, and it’s looking very good! Most of the bugs is fixed from the previous version, as far as I can see.

After some testing, I found some new issues I would appreciate if you could look into:

1 - The changes in Geomux settings goes back to default after ROV reboot. Possible to make fixed changes here?
2 - Seems like it is updating the firmware at every boot, is this right?
3 - The gamepad is working, but there is no delay on the buttons. Meaning that if i f.ex. want to turn on laser, I have to be really quick on the button, otherwise it will turn itself off and on in high speed. This was not in the old software. Where can I fix this?
4 - The motors have the correct direction for up, down, foreward and backwards, but is opposite on left and right turns. How do I reverse the motors so it only affect the turning?
5 - There is possible to assign motor power level to the gamepad, but the option of increasing and decreasing motor power is gone. Would be really nice to have this feature, using left and right triggers to increase and decrease motor power. Since I use Fatshark when flying the ROV, I need to have all essential controls in my hands.
6 - Would like to be able to assign start-stop recording to the gamepad. Can I assign this in some JS file?

Have also sent these issues in a mail to support.

Hope I can sort these things out soon, I’m eager to test the new camera in the sea :slight_smile:

Thanks :slight_smile:


#4

Just to confirm, were you using the image that @badevguru posted on 12-07-16?

Thank you for the feedback about the development image.

  1. If I remember correctly these default setting were set for a mid-range computer so that out of the box (and at each startup no matter what topside computer is being used) the system will be smooth. The video settings are related to how fast the topside computer can decode the video. If we get more feedback from users that persistent changes would be helpful here, we are open to changing this.

  2. It checks for firmware version match at the start of each boot. If the version matches (which as long as you have not made firmware changes it should) then it should not do an upload. Are you seeing it do the check or the full upload?

  3. Thank you for the feedback on this issue. We will see if we can re-create this in the lab. We do not use the Logitech F710 wireless (which if I remember correctly is what you are using) and will see if this issue shows up on the F310 and the PS4.

  4. The motor settings are in the “settings” applet. You can reverse thrusters here just like before.

  5. Thanks for the feedback.

  6. You should be able to do this with the “input” applet to remap all the controls. No direct JS file modification needed.

Thanks again for the feedback.

-Brian Grau


#5

I just wanted to chime in here about the controller

I agree with Rule_Soldal that it is important for folks using FPV headsets/goggles to have all their controls in hand. I have been hoping to set up the triggers to control the AUX servo that controls my water sampling bottles.


#6

Hi Brian,

Have done some more testing, and tested more specific on each issue. Some solved, some new turned up. I’ll feed you with a lot here, so better give you my setup details first:

OpenRov 2.8, sn. 2549, with HD camera upgrade.
Laptop: Lenovo X240, Win10 64 bit, Intel i5 4210U 1,7gHz - 2,39gHz, 4gb ram, SSD disk.
Chrome, Versjon 55.0.2883.87 m
Logitech F710 wireless Gamepad.
Wlan between tether and laptop, but using ethernet cable now when testing.
Image as you mentioned is the latest (I think), OpenROV_31.0.0_Devbuild-2016-12-06
2 external LED lamps mounted. Otherwise in original condition.

The setup is the same as I used with the old camera and old software, witch worked flawless. Well, more or less at least.

First, I wan’t to clarify the points we already discussed, have tested further on these:

1 - Geomux. On my computer, with some testing, I had to reduce bitrate to 3mbit to avoid lag. Could not notice any different in picture quality by doing this, but seems to work quite stable with this. I figured out that the changes in Geomux went back to default when I close the browser tab, and reopened it. Changes stays if I just refresh the tab, and also stays if I reboot the ROV. Would prefer that these changes was saved, so I didn’t have to do these tweaks every time.

2 - Firmware update. Reason that I tought it updated every time, is that every time I power up the ROV, it comes a new message in the “message-buble”, saying “Firmware update applied”. So after playing around with the ROV a couple of hours, I got a whole list of those messages in the “bubble”.

3 - Trigger-happy gamepad. After I did my previous tests, I realized my chrome was not updated to the latest update. So I updated it to the latest version (version nr. mentioned above), and the gamepad worked as it should. Only changes I did between these 2 tests, was the chrome update, so assume this was the reason. So guess if anyone else complains about “trigger-happy” gamepads, they should check the browser update first.

4 - Reversing motors. Yes, it can be reversed in the setting, but that applies for the motor in all situations. Meaning I with this can get it to turn the correct left/right, but then it will go backwards when it should go foreward. This was ok with old sw, so I assume something has been turned around here?

5 - For now I have set right trigger to power level 2, and left to power lever 5, since it’s these 2 levels I mostly use. But to be able to increase and decrease step by step, like with the lights, would be perfect.

6 - There is no assignment for start/stop video recording in the input tab. Only for recording telemetry data. Well, I’m not able to find it at least.

Puh…ok…and now the continuing, with new issues I came across:

7 - After powering up, it’s almost every time missing camera picture. Most of the times it’s enough to refresh the tab to get the picture, but one time tonight I had to reboot the ROV to get the picture. The cockpit comes up ok.

8 - When I change from Gyro to Compass, I’m not able to turn back to Gyro. Tried many times tonight, and only one time was I able to turn it back to Gyro. Refreshing tab doesn’t help, had to reboot ROV to get back to compass.

9 - When recording with the inbulit feature, the video doesn’t show on the playback. The cockpit data is OK. Tried several times. Camera window black in new_ui, and white in mobile_ui.

10 - I had som issues with camera-tilt not working, either with keyboard or gamepad. Checked the wiring, seemed to be ok. Suddenly it worked OK, and was working after. Don’t know what did it. Just mentioning it, don’t put any effort in it, I’ll let you know if it is becoming a returning problem.

11 - Tested some recording with Screencastify. Worked perfect, both in new_ui, and mobile_ui. But after recording the menu/settings buttons did not work anymore (both ui’s). The buttons was working again after refreshing the tab. Tried several times, and was the same issue every time.

12 - Heads-up display. This is just a wish from my side. I would prefer the possibility to have the heads-up display in the middle of the screen, like on the old software. Can this be made as an optional add-on?

Guess that was all for tonight :wink: Still this is only after testing it on my dining table, havn’t dived with the new version yet. And please, don’t misunderstand me, this is not meant as critic or complaining. The new camera and software is awesome! Just want it perfect as soon as possible… Please let me know if you need me to test anything. My ROV is diving-ready, and I have the sea close by here, so I can do dive-tests as well if you need me to.

Rune


#7

Just got a little confused about the DEV versions here now… The version badevguru was mentioning in this thread, says version 2016-12-07 in the link, but the filename says 2016-12-06, witch is what I installed. So I’m not sure if I have the absolut latest image…? I installed the image from the link at the top of this thread.


#8

My bad. You have the latest image. Typo when creating the bitly link.


#9

No problem Brian, I suspected that :slight_smile:

Tonight i did some more testing, and found another issue. This time it’s one specific issue, not a long list…guess that is a relief?

First to explain some expressions, to shorten the text a bit:
Startup screen: meaning the fancy screen telling you “connecting to ROV”, with some wise words below.
WiFi: meaning laptop connected to internet with wifi, at the same time the ROV is connected with LAN cable.
Data: meaning the gyro, depth, batt voltage, and the possibility to get options with the menu button. (This is following…if I don’t get data, it comes up with a blank box when pressing the menu button on top left). These tests is don with mobile_UI)

So here is my sequence:

Running wifi, using DHCP, using the rov.openrov.net address: Startup screen OK, Data OK, video picture OK.
Without wifi, using DHCP, using the rov.openrov.net address: Startup screen OK, no data, no picture.
Without wifi, using static IP address, using rov.openrov.net adress: Startup screen OK, data OK, no picture.
Without wifi, using IP address AND static IP address: Startup screen OK, data OK, no picture.
WITH wifi, using IP address and static IP address: data OK, no picture.
With wifi, using IP address, aut. static IP address: data OK, no picture.
With wifi, using DHCP, using rov.openrov.net: everything OK again, with picture.

Bottom line: I’ve tested this a lot, rebooting, refreshing again, again and again. And seems like I have to have the laptop connected online at the same time it is connected to ROV, to get video picture (and using the rov.openrov.net address). For me, that’s bad news. I’m using wifi from ROV to laptop (meaning I can’t be online on the same time), and maybe most important…you can’t rely on online connection in the field.

If you have problems to replicate my problems with your setup, I’ll be happy to let you play with my system using ex. TeamViewer :slight_smile:

Hope to hear from you guys soom :slight_smile:


NEW PRODUCT - Pro Camera-HD Upgrade
#10

Thanks for the report @rune_soldal, is your ethernet setup for DHCP or is it using a hard coded IP address? One change with the 31 release is that you should now use DHCP on the ethernet connection to the ROV. The ROV functions as a DHCP server and should hand out the IP address and also serve as the DNS server which in turn ensures the rov.openrov.net gets resolved correctly.


#11

Every control should be mappable to the gamepad right now. It may be in our refactor of the gamepad mapping, we have inadvertently removed the incrimental increase/decrease. Will look in to that.


#12

I’m not IT educated, so I see I wrote the report in kind of a funny way. I’ll edit the report. But did try both. Bottom line was that to get picture I had to have the latop connected to internet with wifi, ROV connected to laptop with ethernet cable. IP address set to automatic ((DHCP?), and using the address “rov.openrov.net”. If I disconnect the laptop from internet, picture dosn’t work.


#13

Possible ambiguous naming on our side. The Telemetry recording option also records video when using the HD Video Pro camera. If using the stock camera, you will still need a third party screen recording software for now.


#14

Thanks Brian. You’re right, tested it on the F710, assigned recording to the START button, worked perfect. Expect from no video on playback, as already mentioned.

Tested a bit more on the problem I tried to explain the other day, that the laptop had to be connected to internet to be able to get picture from ROV. This time I powered up with laptop connected with internet with wifi, and ROV with ethernet cable. Got data and picture (had to refresh tab the first time as usual, already explained). Then I disconnected the wifi, so the laptop lost internet. Data and camera still working. Refreshed tab, got no picture, and no data. Connected laptop back to internet with wifi, refreshed tab, and got data and picture back.

Did some testing with the FatShark video googles. Worked perfect specially with the mobile_ui, giving me full screen camera view. But here I have some wishes. I know different people want different things, but at least here is what changes that would make me happy:

  1. Bigger depth display. It’s rather small, and to me it’s important data (diving in steep fjords).
  2. Gyro shoving autopilot active, but no indication on depth autopilot.
  3. No indication on recording is either on or off.
  4. And as mentioned before, would love to have back the old heads-up display in the middle of the screen.

I know I have given you a lot here. As far as I can see now, there is 2 major issues that actual is preventing me from test diving: The reversed motor on turning left/right, and that I have to have laptop on internet in order to get data/picture from ROV. If it was up to me, this would have priority.

Rune


#15

“The https://rov.openrov.net does not resolve if you plug the ROV directly in to a router. In that case you must get the locally assigned IP address of the ROV and edit the host file on the computer you use to connect to the ROV so that rov.openrov.net points to the ROV. While you can connect to https://<rov ip address directly, the cert will be invalid and some features in cockpit will no longer work correctly.”

It took me a little while to understand this. I run my ROV through a router. At first, I was trying to connect using the old method (192.168.0.100:8080), which let me see the cockpit but video wasn’t working. Trying to access through the new address resulted in errors.

To fix this (on Windows 10), you need to open the file “c:\Windows\System32\Drivers\etc\hosts” as an administrator. Then you need to type the following at the very end of the document: “192.168.0.100 rov.openrov.net”. Note that the ip address that I assigned my ROV through the router is 192.168.0.100; yours might be different, and you can figure that out by logging into the router. Save the file, access the ROV through Chrome using https://rov.openrov.net, and–voila–video with the new Beta version of 31.0.0, through wifi!


How to build a WiFi enabled Tether Router setup problem
#16

Thank you SO much IchthyoEcologist, that solved one of my major problems! But I had to use static IP adress, but that’s fine… Now I got ROV running with video, using WIFI between ROV and PC, without any internet connection :slight_smile: :slight_smile:


#17

Brian, I now have only one major problem left, before I can start diving. And that is to reverse the yaw. The motors is turning the correct way going foreward and backwards, but they are reversed on yaw. I have been searching for somewhere to change this, using cloud9, but I just can’t make it work. Can you please give me a hint on where I can reverse the motors on yaw, without changing the foreward/backward direction? Thanks :slight_smile:


#18

@rune_soldal,
It sounds almost like you do not have the correct pitch propeller on one of the horizontal thrust motors?
Regards,
TCIII AVD


#19

TCIII, thanks for the tip, but I’m afraid it isn’t that easy. I had a more detailed description in an earlier post in this thread, but can explain again. With the previous firmware, it was working correctly, and had a year with diving with this firmware. I upgraded to the Pro HD camera, and installed the 31 beta version. No other changes was made to the ROV. After this, the yaw controls was inverted, meaning turning right, made the ROV turn left, and visa versa. This applies to both the keyboard and game controller. Got a tip about reversing the motors, but that off course gives another problem, the ROV going backwards while it should go forward. I started to worry about maybe it was my mind playing me a trick, so today I tested it in water, and I was right. Video attached showing the problem. Am I the only one with this problem on 31 Beta? To me it seems like this should be a easy fix, but I just can’t figure out where do do fix it in the sw. Hoping someone can help me out with this one, this is the last major bug that is preventing me from diving. Any tip is much appreciated! :slight_smile:


#20

Another simple suggestion that you’ve likely already tried…but could you just invert the actual sticks in the logitech app for the gamepad? Can’t remember if you can independently invert the x and y axis.