Need help uploading firmware to ROV


#1

Dear OpenROV Supporter,
Dear Badevguru,

I’ve followed your instruction for compiling and trying to upload the OpenROV firmware. More precisely, I’ve connect the Beaglebone Board via USB to my MAC computer and run “firmware-installfromsource.sh”.

During compilation everything works fine except for these warnings:
mv: cannot stat ‘/tmp/tmp.IuSYmkBbO1/src/Device.cpp’: No such file or directory
sed: can’t read /tmp/tmp.IuSYmkBbO1/src/Device.cpp.template: No such file or directory
rm: cannot remove ‘/tmp/tmp.IuSYmkBbO1/src/Device.cpp.template’: No such file or directory

Anyway the compiling process can successfully terminate. During the update phase I receive this message:
Arduino reset set high, Arduino enabled.
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

I’m unable to get rid of it. I tried first by only connecting the Beaglebone board (no OpenROV Controller board connected). Then I also tried by mounting the Beaglebone board on top of the OpenROV controller board, and I couldn’t success either. Do I need to mount also the Tenda hardware? Do I need to power the Beaglebone board from the 5V supply?

Thank you for your help.


Updating the Arduino firmware code
#2

The firmware updates the Arduino that is running on the controller board. When you connect to the controller board, are you able to see telemetry data in the cockpit, thus verifying the controller board and the beagle one are talking correctly?


#3

Actually, we were not able to see any telemetry data. We’ve discovered that the Tenda connector was not properly connected. Thank you very much for your help.