Need help identifying old ROV and advice on getting it functioning

Hello openROV community, I am a new member and recently was given an in-progress ROV project my friend started years ago. I’m pretty excited to get it working and in the water, but I’ve been having trouble figuring out what I will need to make that happen.

What I know about the project is thats a bit old, I remember when my friend got it about 7 or 8 years ago if thats possible. It is mostly built, though it looks like some things are unplugged inside the electronics tube and the tube is not mounted to the frame of the ROV. Compared to photos of other projects I’ve seen, the wiring on mine looks like a bit of a crows nest haha but we’ll see what happens. I have a good amount of experience programming arduinos, though Ive never worked with a beaglebone so that will be a learning curve.

My main questions are:
what model ROV is it?
what software will I need?
Is it even feasible to get this thing working without upgrading everything or is pretty outdated at this point? (The goal is to get this thing functioning with minimal investment, other than time)

Hopefully these images are descriptive enough, if anyone wants more I’ll add them, and if anyone has advice it would be greatly appreciated!



1 Like

some more photos I forgot:

I have a Beaglebone white with the Open ROV arduino cape and the single pair network adapters for the umbilical cable (orange cable in your pic). I had all the hardware and laptop interface working but never built the frame. It was one of my many unfinished projects. This is all I have left, but I can’t remember my password to login to the Beaglebone. I’ve tried over ssh, but I fail repeatedly. username is ROV I think. I can’t remember the link for the web interface either.Seeing your pics makes me wish I had finished it. If anyone ever reads this and needs these parts, I am open to offers.

I’ll be looking for what the default password is for these older generations of OpenROV.

1 Like

Well thats exciting you had the hardware and laptop interface working! That is what I am trying to do currently. Do you remember what software you had for your laptop to interface with the ROV? that is what I am having trouble finding

My version : username rov and password is OpenROV

Resources here for the build, pw’s and ip’s / urls for several versions. Hope this helps !

I use ssh in a terminal window using a Linux or Mac. Open a terminal, and use the following command

ssh rov@

You will need to know the I.P. address to do this, mine just happens to be plugged into my home router. When prompted for a password, enter OpenROV

You can navigate to the web interface using Chrome, point it at the same I.P. address on port 8080, like this:

If you are directly using the umbilical, that I.P. address won’t work. I can’t remember if it is ‘localhost’ or the numbers for localhost. That will be my next check. Here is a pic showing how old interface looks way back when.

Thanks a lot, I will give that a try today

@Subseaexplorer thanks for the build info, I found the v2.5 release and flashed my sd card with that as it seems to be the only version compatible with the cape ROV’s (Which I assume is what mine is because the board says “cape” on the side but I’m not really sure what that means)

@Sammy_Real I used your method with the ROV plugged into my router and was able to stream video from the camera. I don’t yet have control of any motors, from what Ive read I need to upload the firmware from the sd card to the arduino, which is an option in the web interface. However when I tried that it seemed to get stuck endlessly loading. I’ll mess around some more with that later.

1 Like

I think I have the same cape, See if it looks like the one I put in my pics above. I seem to remember having the cape fully operational, controlling the lights, ESC/Motors, and I think it may have had a camera tilt? I don’t have any of those items anymore. If you can’t get nothing to work, I can send you my sd card image and you van give it a try.

Yeah it looks the same to me. Im stuck at trying to upload firmware to the arduino, if you have the old sd card image to send that would be great. The 2.5 release does not seem to work for me.

Sorry I didn’t check in sooner. How can I get it too you? Digital upload somewhere of just mail you a copy. Let me know.