Motors constantly running after boot up


#1

Hi Folks,

I have been having some issues with my V2.4 Kit.

After the boot up all 3 motors spin at full speed.

Straight after the ESC is calibrated (3 beeps) that motor runs constantly at full speed.

I have uploaded the new Ardrino firmware, I have removed the servo power jumper, I have programmed my ESC's multiple times and I have calibrated my ESC's multiple times.

Arrow keys and crtl shift have no effect.

Nothing seems to stop the motors from running constantly, I cant stop them using the diagnostic tool either.

Any Ideas?

Thanks,

Adam


#2

Couple things to try out:

What happens when you pull of the diagnostics screen in the cockpit? Technically it disables all input. As you move the sliders it directly sends the desired speed (for lack of a better term) to the particular motor.

With sliders in the middle, the calibrated motor's should not be turning.

In the telemetry portion of the cockpit you should see measurements for the motors, mtarg: for target speed and motors: for actual speed send to the motors. With code updates in the last 6 months or so, motors: should read 1500,1500,1500 which is the neutral for each motor.

On the calibration, when using the diagnostic screen to do the calibration you first go full, then full neutral, then neutral. After calibration each individual motor should be stopped.


#3

I had the same problem until I realized I had the ESCs plugged into the wrong pins on the cape. Might be worth double checking: http://wiki.openrov.com/index.php/File:CapeWiringDiagram.jpg


#4

I spent another few hours on the ROV today, but still no luck...

When I goto the diagnostics screen there is no change, the motors still spin continuously.

There is a green and red light from the escs.

I have triple checked my configuration, (Everything is plugged in right)

I have updated the SD card and the ardruino and re calibrated the ESCs, still no love.

And to make matters worse the camera is no longer working (Did before).

I am pulling my hair out, any help would be greatly appreciated!

Adam


#5

Hi Adam:

Just to double check- make sure that when you calibrate the ESCs, you only have one ESC switched on at a time. If you have multiple ESCs switched on when you try to calibrate one, bad things happen.

If you've checked everything three times and are still having problems, it sounds like you might have to bring in some other instrumentation to try to figure out where the problem is.

Think about getting a servo tester, if you don't have one already or don't know somebody who does. You can get one for about $5 on Amazon, or you can get a fancy digital one for a little more. With a servo tester you can unplug the ESC servo lead from the cape, plug it into the tester, set the tester to neutral (1500 usec pulse width), and see what happens with your motor. If the motor is running, then there's something wrong with the ESC (it either needs to be reprogrammed, recalibrated, or is broken). If the motor is not running, then there's something wrong with your BB/Cape/ROV software combination.

Good luck and let us know how it turns out.

-Walt


#6

Hi folks,

I finally got everything working perfectly. I just had a slight calibration error on the Port motor. (Motor turned occasionally with no input).

When I removed the power (unplugged the batteries) to do a ESC calibration, everything stopped working. Its like when I turn off the power the Arduino looses its code...

I go back to the start and manually reprogram everything again (SD Card, Arduino and updates) - it works, but only until I pull the plug on the batteries.

what am I missing here???

Thanks,

Adam