Motors and control


#1

Hi All,

me again. Anyone been following my progress knows i sent my kti back tot he guys at Open ROv to try and sort some issues. Well it arrived back today, I madly hooked it up and it worked, well sort of. I have a couple of issues

first up, control of the motors. When i use the up arrow, both the port and starboard motor run, in counter rotaion. When I use the down arrow, the starboard motor runs. Using the right arrow both port and starboard motor run in the same rotation and using the lft arrow the starboard motor runs only. shift and control run the thruster quite nicely. Any ideas?

also, i am experiencing delays between sending commands and motor activation, like uopwards of a sec or two. Simialrly the camera expereicnes delays of up to a second, spasmodically.

and while I'm at it, the cape just up and dies on me occasionally when you run the motors. The red light goes out, the system reboots and about 30 sec to a minute later the system resets itself.

any ideas gratefully accepted

Jamie


#2

what version of the openrov do you have?

what kind of batteries do you have? it seems like the voltage is dropping when you active the motors.

motor controll problem; have you performed both the calibration and programming of the motor controllers?

http://wiki.openrov.com/index.php/Programming_the_ESC


#3

Hi Thomas, version 2.4, running off a regulated power supply at this stage. Have preformed the callibration and programming

thanks

Jamie


#4

i would perform the calibration and programming again, but disconnect all other esc's while doing the calibration and programming.

what voltage and ampage is the powersupply rated at? you should have atleast 2-4amps available just to run it in air, in water you should probably have about 10amps available.

10-12Volt.

what propellers are you using? the delta 15 props is very inefficient, and draws alot of amps, changing to the graupner props will greatly decrease the power need.


#5

Jamie, the controls are probably off in the software. Mine were.

I have V2.5 so I was able to fix it with the cloud 9.

I am getting the delays as well.

If you run the motors at high speed the ESC's overheat and something shuts everything down. I don't run the ROV on a power setting of 5, only 1 or 2 - sometimes 3. Never dies when doing that.


#6

Hi Thomas

thanks for the reply. I've reprogramed recalibrate till the cows come home, and you never really seem to get the same issues each time, all you get is not the right combination. Driving me batty! Power supply is 12 volt capable of delivering 10 amp and I'm running the whole thing on the desk with no props on the motor

thanks


#7

Hi David,

yep, thats what I'm startying to think, ie the software is off, justr trying now to work out how/when/why to program and which bits. I'm fast coming to the conclsuion that either a) you need to be an electronics guru, a programing guru and have a truck load of time to make this work or b) be prepared to ebcome an electronics guru, a programmer and have lots of time!

oh well, back to it to see if I can make it work

Intersting re the overheating of the ESCs Like the idea of dropping the power settings, nice!

thanks for your comments

JAmie


#8

Jamie,

I'm not sure about V2.4. Is it running the latest software release? If you have the latest software release it is very easy to login and update the code for the keyboard.


#9

If you have the latest software release, not sure if it works on 2.4?

I used the 192.168.254.1:3131 port and cloud 9 to edit the keypad configuration file.

user: rov

Pass: OpenRov

Browse to src/static/js/keypad.js

These settings did it for me:

var KEYS = {
32: { // space (all-stop)
command: 'stop'
},
39: { // up (forward) actuall right originally 38
command: 'command',
position: 'throttle',
value: 1
},
37: { // down (aft - reverse) actually left originally 40
command: 'command',
position: 'throttle',
value: -1
},
40: { // left (turn left) actually reverse originally 37
command: 'command',
position: 'yaw',
value: -1
},
38: { // right (turn right) actually forawrd, originally 39
command: 'command',
position: 'yaw',
value: 1
},
16: { // shift (lift up)
command: 'command',
position: 'lift',

Not sure if those are the settings you need, but you can figure it out pretty easily.