Loaded new stable image and now nothingw roks


#1

Hi all,

I've had a series of issues (some we have solved, some we still have no idea about), but the major one at the moment is I have no camera/lights of motor control. I have loaded the new "stable image 2.4" as the other image I had did not allow me to access the motors, but I could control the lights.

The issue I have now is I have loaded the new image (several times) and now can not upload the arduino file. When i go to the cockpit windo and go to settings the upload button is greyed out (which it was in the old image as well) and when i click on it I juist get another screen and it fails to see any files. Add to that is that i know cn not make the camera go (yes, have gone to a static IP address). the camera worked on the old image. Interestingly i could not get the arduino code to upload properly on the old image and had to do a manual upload, (and I am about to go and do that again) but what what worries me is that the camera deosn't work, and if I undertsand things, it runs off the beagle bone so it should work, yes , no?

any ideas GREATLY accepted thanks

JAmie


#2

Hi Jamie:

I noticed that there weren't any responses to this yet.

Have you made any progress with the new software, or are you still stuck as described above?

-Walt


#3

Hi Walt,

yep, no responses. Came to a grinding halt. Even reloaded the old image on and had no joy. The guys at Open ROV were out of ideas as well. End result, put the whole thing in a box and shipped ti back to the guys at OpenROV. They are going to have a look at it and try and sort the problem. Stay tuned and I'll keep you informed as to the end result

Jamie


#4

Ok, Hi All,

as I've had several people ask me if we have solved this issue, I figured it would be best to give an update. Had no luck fixing it so the guys from Open ROV suggested I ship it back to them. It arrived back in the US only for Eric and crowd to go "hey it worked straight up". Grrrr! Eric then upload new software etc and is sending ti back. At any rate, it works in the northern hemisphere and is being sent back to the southern hemisphere to see if it works on my system. Stay tuned for an update when I get it back. PS thanks to the guys at OPENROV who have gone out of their way to help solve the issues!

Jamie


#5

I'm having the same issue now. Everything was working fine. I loaded the new image last night and tested it out. It was working fine.

I came home from work and tried to get into OpenRov. I cant get 192.168.254.1:8080 to open at all. I have checked all my settings taken the boards back apart, checked all connections, all the lights come on, tried it on another computer. No luck. I cant get back into the ROV!

Any assistance appreciated.

- David


#6

Hi David:

- Can you still SSH into the BeagleBone? That might provide clues as to what's going on.

- If you think it's the new build, load up a different micro-SD card with the old build, and give that a try.

- Also, try walking through the anomaly flowchart that Eric is putting together. Link here. It's a work in progress, but we need cases like this to expand the flowchart.

-W


#7

Thanks Walt.

"All three lights on" is a no. Only the two outer ones are one but I have no idea which light corresponds to what?


#8

If the center light of your topside adapter is not lit, it means there is no Homeplug connection over the tether between the topside adapter and the adapter in the ROV. Check the lights on the adapter in the ROV (you'll have to peek under the BBB to do that), and check all your tether connections.

-W


#9

Alright. I can verify the home plug adapter on the ROV has the 5V coming in from the tether. I also verified it has the 3V on the other side going into the board? The ROV light is still not on for either home plug adapter (center light). When I attached the BB it lights up fine. The PWR led is on to the ROV 2.5 board. The last orange BRX led is blinking non-stop.

I did notice that after I had booted the ROV up last night the SD card wasnt inserted. I of course inserted it. I tried reformatting and reinstalling the img file for both versions. Still no luck

12V from battery tubes are coming in fine.


#10

Testing the Beaglebone

When I hook it straight up to my router, and plug 5V mini usb to power it, the open rov cockpit is detected. When I get into it and try to run start.htm it tries to connect me to http://192.168.7.2:8080/

It does get a DHCP address from my router.

When I open the address from the router with :8080, it brings me into the cockpit software...


#11

So it sounds like the issue is in the homeplug adapters- the center light should be blinking on both the topside adapter and the adapter on the controller board.

Interestingly enough, this was pretty much the same symptom that Jamie had when he ended up mailing his ROV back to OROV HQ (see above). His ROV worked once we reassembled it on the workbench. So we were never able to figure out what the issue was.

I would recheck all the wiring in the topside adapter. Since the ROV is powering up, it's clear that 5V is getting sent over the tether. But check that the two tether leads to the homeplug adapter are both solidly connected as well.

For the adapter inside the ROV, are you getting the outer two lights? There should be one for power, plus one for the Ethernet connection. The Ethernet connection light will only be on when the BB is attached to the controller board, so you'll need to peek underneath the BB somehow.

If that looks good, but you still don't get anything on the center light, I would try to hook up an experiment where you remove the homeplug adapter from the ROV, and test it on its own paired with the topside box. You'll need a 3.3V power supply to power this adapter, plus a short length of paired wire to hook it up to the topside box.

-W


#12

Thanks for the tips. I have done everything you listed expect the last step. The BB lights up, the RJ45 lights are on, but neither center light is on on either home plug adapter. They have reset buttons I have tried using with no luck. I haven't had a chance to test them unconnected from the BB.

I tried to leave the home plug adapter on the ROV hooked up to power after removing the BB, then ran an ethernet cable directly between them. Didn't seem to change the lights. Not sure if that was even a valid test.

During my first test dives I did get water in the electronics tube. The only board that got wet was the V2.5 open rov board. It was dried and functioned fine afterwords for two days. I was able to get the newest image installed, ect, with no problems. It is hard to think I got water damage that took two days to show up?

I am suspecting it may be the home plug adapters.


#13

Okay, I did the test you recommended. I got 3.3 V to the 3.3V wire on the rov side home plug. I then ran two wires between them to see if the center lights would come on. No go? Any idea how to troubleshoot these things?


Thanks!



#14

SOLVED!!!!

After consulting the manual for the home plug adapters I discovered they have three modes.

Reset / Pair / Power Save - I had inadvertently set them to one of the modes other than default!

To get them back to factory settings you have to hold the reset button down for about 30 seconds, the lights blink, then it goes back to factory. Everything is working again. Whew.

I wasn't sure if I was able to reset the ROV side while attached. So I hooked it up to an external 3.3V to reset it.

Info:

System Restore/Pair:
Press for 1‐3 seconds to secure the network and pair with other
adapters.
Press for 6‐10 seconds to disconnect from the existing network
to save power.
Press for over 12 seconds and the system will be restored to
factory default settings.

(Note, the 12 seconds didnt work. I just held it until the lights cycled.)


#15

Downloaded the 2.5-05 image and it doesn't appear to be working. No IP address from DHCP or direct connection. Loaded the 2.5_01 image and I have an IP address video and lights. Still no servo and no thrusters.


#16

Try loading the new one again. It took mine 2 times to work right :)


#17

I also upgraded to 2.5-05 - After some trouble i got everything to work. Except the servo does not move even though the regulation is shown in the cockpit.

Do you know what might be the problem?

Also the IMU depth seems to not work. However, i did not really tinker with it up to now.


#18

Check your web browser, turns out I couldn't connect to the cockpit using an oldish version of Safari, problem solved by downloading Chrome.

Also, there is a mention in the wiki somewhere that you should wait for the red led to come on to indicate it has completed the startup sequence but mine works fine and it never seems to come on, the BRX led flashes non-stop also.


#19

Did you ever get the IMU working? I am having the same problem.


#20

Thank you David. I'm hoping this will solve my issue with the home plug adaptors.