Left turn reboot issue under water


#1

I have version 2.6 with the latest software

When I execute a left turn under water the system will shutdown and reboot after a few seconds. It will turn for about a second then reboots.

This only happens in the water on dry land it works fine

The unit will go forward , backwards or right turns no issues under the water.

I am not sure what to check for?

I was originally thinking a short under the water but that makes little sense as i would think it should fail during any movement.

I searched the forum and the only thing I can find is a power surge... but there weren't any details as to why or what caused it.

So I am hoping somebody has an idea for me to check.

Many Thanks in advance.


#2

Hmm... if you go into "Diagnostics" in Cockpit and try to move each of the three motors in either direction using the slider bar, do any of those actions cause the same behavior? Also, give some resistance to the motors (like have the cone of the prop rub against a piece of rubber to create drag on the prop) does that cause the same problem?

Let's see if we can rule out shorting from water vs drag or direction related issues.

E


#3

ok I spent some time after I posted doing more searches on the forum here and came up with this link

http://openrov.com/forum/topics/rov-work-on-land-but-not-i-sea-water?id=6365107

Thank you for the Reply Eric I tried what you suggested first and it worked fine.

after reading the above post I tried Walts fix

https://github.com/OpenROV/openrov-software/pull/243/commits

the problem is it is too much power draw on the TrustFire batteries. I have my thrust set to 2.

basically the overload protection is kicking in on the batteries. After I implemented Walts fix the problem is gone.

when I put the thrust to 5 and push forward the board shuts down. so its definitely the batteries. I did check the short issues with the motors and I had no issues there.

hopefully this will help some else.


#4

Hi, I've been having similar problems to what you are describing (we lose power on the ROV after maneuvering around for about 10 minutes, even with thrust settings set to 2 or lower, and this happens consistently), so I would like to try the overload protection software fix. I must confess that I am a code newbie, so I am not sure what to do with the code in github. where should I copy/paste this information, and how?

Disclaimer that we have put in an order for the new recommended liFePO4 batteries and adapter already, but it is out of stock apparently, so we have to make due with the Trustfire batteries we still have in hand.

Thanks for any advice anyone has :)


#5

Hey Beth O,

I had this same issue and doing the software modification helped me out on low thrust settings.

Watch this video from Brian to see how to connect, if my instructions don't work below. ( https://www.youtube.com/watch?v=Wwb-aG9Yblw )

- Connect to your OpenROV through the browser: 192.254.168.1

- I stopped the OpenROV Cockpit and started Cloud 9 IDE

- Connect to the Cloud 9 IDE: 192.254.168.1:3131 (you might have to refresh to get rid of the session ID error.)

- On the left in the window if all goes well, you should see a file menu. You want to navigate through the folders/files to: src/plugins/rovpilot/public/js/rovpilot.js

- Once here, open it up and scroll almost all the way to the bottom. You will need to find the line of code and change it according to the following link. https://github.com/codewithpassion/openrov-software/commit/d296d8c8c52a8111a78e614cc6090e4d7b3a24ab

Once this is done, the change is saved on the file system on the ROV, not on the Arduino. You will need to re-start the Cockpit and shut down Cloud 9 (I do this not to burden the BeagleBoneBlack) Under the settings tab in the OpenROV Cockpit, you will need to re-upload the firmware and the changes will be made.

When I did this, I double checked on thrust setting one that the left/right turn didn't go to full speed. I can run the ROV in thrust setting 1 and 2 no problems. I believe it also worked for me on thrust setting three. I can use thrust setting 4 & 5, but only forward/back. I will be ordering the new batteries to overcome the issue.

Hope this helps!

Mike