LEDs and Motors not working


#1

We assembeled the ROV ver 2.5B and we have connection on the computer. The camera is working fine.

  1. The LEDs do not light up
  2. The motors including the servo are not functioning at all.

Can someone help please?


#2

Have you uploaded the Arduino code from the cockpit yet?

Do you have any telemetry on the right side of the cockpit?

Can you move the Camera Servo?


#3

Hi David.

The answer to your questions is no. We were not able to upload the Arduino code since the instructions we found were a bit confusing. We are facing the same problem with the programming of the ESCs

Any suggestions would be appreciated. Thank you again David.


#4

Hi Giorges

You can first try to install jumpers on J12 & J17 on the control board to make sure you have power to everything, this bypasses the need to use +5V from the tether to turn things on for bench testing.

There are switches on each ESC to turn them on and off, see the instructions on how it is used to program them.

If the above does not work I would start by downloading this image from the GIT to a windows system.

https://github.com/OpenROV/openrov-software/releases/download/v2.5....

Use a utility called Win32DISK.exe to burn the image to a new sd card keeping the old one as a backup if you like.

This image will work with no changes needed.

once installed on the ROV and you browse to the cockpit, open settings then hit the Upload firmware button, select details to see it execute the upload files and it should come back and say successful.

Note: nothing will work until you get the Arduino code uploaded except for the BBB, camera and browser cockpit.

Then program the ESC's as per the instructions, do these one at a time switching the other two off as you do them.

Once you have them all programmed then you should be able to Calibrate them using the Diagnostics in the Cockpit.

let me know how you make out.


#5

Thanks David. I will do what you suggested and let you know how it goes. I really appreciate your help.


#6

Thanks David. It all worked great.

We are facing a new problem if you can help me again.

The three propellers are not all the same. One of them is different. Do you know which goes where?

thanks in advanced.


#7

You need one off each on the Back Thrusters

The Vertical does not matter


#8

Thanks. I appreciate your response


#9

Hi again David. I want to ask one more questions. The OpenROV is completed and it all seems to be working.

I have 2 more questions before we decide to test in water.

  1. One of the motors seems to be turning the "wrong way". Does this have to do with the connections? Meaning, when we connected the motor cables we did not consider the order we connected them. Does this matter?
  2. The vertical motor turns only in one of the directions. WHen we try to turn it in the other direction it does not turn most of the times. Does this have to do with the motor or something else?

Thanks and i hope you are not getting tired of my questions!


#10

The motors in the back will turn in opposite directions this is because you have a right turning prop and a left turning prop. This is done to counter balance the tourque of the motors to keep the ROV stable in the water.

there are settings in the cockpit under diagnostics that can change the direction of the motors so there is no need to worry about how they are wired up.

You must make sure you program & calibrate the motors according to the instructions. If after calibrating the motors you still have issues then there is a possibility that the Vertical motor may have a short. you can use an ohm meter to measure the resistance between the pins and they should measure .4 ohms. also measure from each pin the case of the motor and it should read open and not 0 ohms. you can do this at the DB25 connector, If it does then you have a winding shorted in the motor to the case.

but I suspect your issue to be in the calibration.


#11

hi David. Here I am asking you another question. Hope you do not mind. I posted a new item in the forum but I did not receive an answer so i am writing here. I am posting the text here as it was written in the forum item:

We have a 2.5B OpenROV. Everything was working fine on the OpenROV until the last few days.

Recently, we do not get a connection between the top homeplug adapter and the one on the bottom (on the ROV).

  • Only the middle LED blings on the TOP homeplug.
  • The two outer LEDs stay ON on the ROV homeplug.
  • On the ethernet connection of the Beaglebone we have a green and yellow light ON when connected to the ROV homeplug.

Note: when connecting a regular ethernet cable between the PC and the OpenROV (directly to the Beaglebone black) everything works fine.

Any help would be appreciated. Thanks in advance.


#12

Reseat the Homeplug adapter under the BBB on the Control Board. If that fails then you can try resetitng the homeplug adapters so the sync to one another. there is a rest button on each homeplug adapter but I would have read up this but I think it's jsut a simple matter of pressing the button.


#13

I have the same problem. Have tried averything, reseting, repairing etc....still same problem...I have video...that's all


#14

UPDATE:

Problem solved.

Needed to re-upload the image.

Guess if you use another laptop then you have to do this again. New image to new laptop.