LED & board trouble


#1

Just finished my ROV.

One of the LED panels never worked.

The first one worked for a while, but now it can not be lit through

ROV instructions.

However, if I apply 12v directly onto the LED array terminals it shines.

Also, the board powers up even if I have not connected the tether to 5v (USB).

Is my ROV board somehow bad?

I was thinking maybe some component that is supposed to drive the LED array

is broken, has a short in it, and thus the whole board gets powered up?

As you can see I am a bit of a novice.

Any help is appreciated.

Marco


#2

do other functions work? motors, Servo etc.

Is the LED connector reversed where it plugs into the controller header.

If that is ok I suspect that the Arduino code is not loaded correctly.

try reloading the Arduino code, if that fails you can also try getting the latest image that Brian just posted and burn to an SD Card and follow his instructions.

As for the ROV Powering up with out the 5V on the tether. this will happen if there is a jumper installed on J12 or a possible trace on the PCB shorted in that circuit.


#3

Thanks David. The motors & laser are working well. I have not jumped J12. I think that one of the LED arrays may have had a short in it. Could that have killed some component on the main board? When I try to light the LEDs I am not seing any voltage on P1+/- Could the component driving P1+/- have died? And would that result in the board powering up without the tether? Thanks, Marco


#4

The LED modules are driven by Q4. If you have a voltmeter you should see +12V on P1+ all the time, the led module is switched off and on by switching the gnd off and on. for testing you could insert the +led of the led module in P1+ and use a small wire to short P1- to gnd, which should turn on the LED module. Or a resistor of 1K if you have one just to limit the current in case you accidentally try shorting the wrong pin (+12V) to gnd.

It could be that Q4 was damaged. If you had an oscilloscope you could look at the input to Q4 to see if you were getting a signal to turn it off and on.

an easier test would be:

If you don't see +12V at P1+ then there is a resistor R28 that may have blown.

one test that you can do is apply +12V to P1+ and connect the LED Module gnd to P1-

then you should be able to turn it on and off if Q4 is working ok.


#5

Hi David,

Thanks for the tip.

I only have a multimeter.

Across R28 I can not measure any voltage when the board is powered up.

When I use the Ohm meter I get 0 Ohms. I guess like a short.

Through a magnifying glass I can see "000"

written on the resistor, and can not see any visible damage on it.

When I tried to measure the voltage across R28 the LED

array came on. Freaky.

-Marco


#6

... also, across R26 (which also has "000" on it) I measure

1K Ohm. Across R28 0 Ohm.

I guess that means it's dead...


#7

... and on the web I see that "000" designates a jumper.

So perhaps it should have 0 Ohm resistance...


#8

You will have to measure DC voltage not resistance from Gnd to P1+ to see +12V

You will also have to measure DC voltage from Gnd. to R28, you should see +12v on both sides or R28 with your meter Black lead to gnd Red Lead to either side of R28


#9

Hi David.

I see 5v between GND and both R28 terminals.

I checked that the battery packs are both delivering 12v.

The BBB is not even connected when I do these tests. Should it be?

-Marco


#10

... and GND to P1+ is 11.2v

GND to the Q4 terminals is 0v and 5.5v on one side, and 5.5v to the other side.

The LEDs are shining, but not at their strongest.


#11

There are 3 resistors that can be used from power source and a jumper selects which one will be used. By default R28 +12V should be used.

R24 connects to 3.3V power bus

R25 connects to 5v Power bus

R28 connects to +12v Power bus

It could be that you measured the wrong resistor.

please measure the voltage between gnd. & at P1+

and tell me what that is.


#12

Hi David,

GND to P1+ was close to 12v

Marco


#13

Ok so all is ok at this point and you have +12V on P1 + that is a good thing.

If the lights are on but not bright it's because you do not have the BBB connected and the input to Q4 is floating and it may be turned on partially.

The issue then is with Q4 not getting turned on and off to pull P1- to gnd.

Can you still turn the Lasers on and off?

Do the Motors still work?

Does the Servo still Work?

I suspect at this point that you need to reload the Arduino code.


#14

Hi David,

Thanks for all the help.

So I reloaded the Arduino code.

Now I see the following:

Lasers, Camera, Servo, motors and IMU all OK.

2 problems remaining:

1) The board still comes on without the tether voltage.

2) The LEDS are behaving strangely.

The "i" key toggles them, but just from bright to dim. They are

on the whole time.

I measure a voltage of 5.5v across the terminals of the LED.

What do you think?

Is that Q4 component dead?

Thanks,

Marco


#15

Doing a DC Voltage check is not an accurate test because the voltmeter does an RMS reading. Which means it takes an average of what the voltage may be and in this case you are measuring a DC voltage that is pulsed on and off in order to create the illusion that the LED's are dimming. So in short you can't accurately use a DC voltmeter to measure this and oscilloscope is what is needed . Having said that if you are able to use the i key to toggle them on and off then we know the Arduino and code is working, we know that Q4 is partially working but it could be that it is not completely turned off allowing a path to gnd thus turning on the LED's. if you measured 5.5v on - led of the LED Module to gnd that means that Q4 is partially turned on or leaking to gnd. If Q4 was turned off completely the voltage between LED- leed to gnd should read +12V and the LED Module would be off, if you measured 0 volts then the LED module would be on full brightness.

So you either have a problem with Q4 or

the input that turns Q4 on and off is not working the way it should.

I am suspecting Q4 to be the issue, a short on the led Leeds or a bad module could have damaged it.


#16

Thanks David,

If Q4 is indeed damaged, what do you think my options are?

Is it realistic that I could buy a Q4 replacement part and succeed in removing the bad one and attaching a new one?

Or would I have to buy a new Arduino board?

Thanks,

Marco


#17

https://github.com/OpenROV/openrov-electronics/tree/master/OpenROV%20Controller%202.5B

Here is the schematics for the 2.5 controller

go down until you see PWM's for Lights on page 6

this will help you to troubleshoot. You can change Q4 but it is very small and not easily soldered. Check with David or Walt they may be able to help


#18

Hi Marco

Check to see if R40 is still on the control board if it is missing that could cause the input to Q4 to float and partially turn it on.

I am suspecting that Q4 is ok because you can turn it on and Q4 pulls the P1- to gnd to turn the led's on full brightness.

one test would be to use a 10K ohm resistor and touch it across R40 to see if the lights turn off.


#19

Thanks again David.

Well Q4 is physically still on the board.

But I would not say that the LEDs are attaining full brightness.

They seem to shine brighter when I feed them directly with 12v.

And if Q4 is not dead, then what do you think may be going on?

Also, we have the fact that the board powers up even without 5v on the tether. Could a broken Q4 somehow be leading to a power up on the board?

Marco


#20

Check to see if R40 is missing not Q4