Latest software release candidate (RC6) now available


#1

This is hopefully the code that we will go to general release in the next week or so. For those that are completely risk adverse, go ahead and wait. If you do want to help us make sure the release is ready for primetime, we would love your feedback. Instructions below:

https://github.com/BrianAdams/openrov-onrov-suite/releases/tag/v2.5.1-RC6

This will hopefully be the final release candidate. Please focus testing around:
1) Consistent startup with the motors moving as expected
2) Easy and consistent update workflows.

This is the first release where we have switched to the suite concept. The suite simply combines the sub projects we are using to build the image we put on the ROV. This also simplifies the upgrade process as we no longer expose upgrade detail for each sub project, just the suite itself.

As a result, we have moved our releases to the openrov-rov-suite repository on github.

Upgrade instructions: If you are already on Release Candidate 3 (which is shipping with 2.7 ROVs) or above, you can use the built in upgrade feature instead of burning a new SD card of the image.

Built-in upgrade feature:
1) Go to dashboard (http://192.168.254.1)
2) Choose software
3) Click the green Enable Software Updates button
4) Agree to the terms of use
5) Under branches, choose pre-release
6) Uncheck "show only updates" option
7) You should see an entry for openrov-rov-suite at a particular version
8) Choose install of the openrov-rov-suite
9) After installation open cockpit (http://192.168.254.1:8080)
10) Go to settings, choose to update firmware, follow instructions

Burning a new SD card:
OSX instructions: http://community.openrov.com/forum/topics/checklist-burning-an-image-to-an-sd-card-on-osx-via-the-command
Windows instructions: http://community.openrov.com/forum/topics/instructions-burning-sd-card-image-on-windows


Note: As a release candidate, we encourage running off of the external SD card. If you want to commit the image to the eeprom on the beagle bone black, you can by ssh'ing on the rov and running "sudo /opt/openrov/cockpit/linux/copy-to-emmc.sh" after which you can remove the SD card.

Manifest:
openrov-avrdude 6.0.1-4
openrov-cloud9 0.7.0-4
openrov-cockpit 2.5.1-94.45c7d1
openrov-dashboard 2.5.1-55.251364
openrov-dtc 1.4-4
openrov-ino 0.3.6-9
openrov-mjpeg-streamer 2.0.1-7
openrov-proxy 0.1-20
openrov-samba-config 0.1-5
openrov-arduino-firmware 2.5.1-master.126.b62f5c4

Feel free to come discuss with us on gitter: https://gitter.im/OpenROV/discuss ;


#2

Hi

After I now have updated to RC6 my motors are running incorrect.

Forward is = turning and visa verse.

I can not correct this in the diagnostics anymore :(


#3

Hi,

After doing this update (from 2.5.0-rc3, via SD card), I was not able to connect to the ROV as before, using a DHCP-provided address. I found the problem to be caused by the following lines at the bottom of /etc/dhcp/dhclient.conf. When I commented them out, everything worked fine again. Is this an intended, permanent change for some purpose, or just a leftover from some test?

timeout 5;
lease {
interface "eth0";
fixed-address 192.168.254.1;
option subnet-mask 255.255.255.0;
option routers 192.168.254.1;
renew 2 2037/1/12 00:00:01;
rebind 2 2037/1/12 00:00:01;
expire 2 2037/1/12 00:00:01;
}


#4

I have tried to remount the upload several times with no success. I still couldnt get the oportunity the reverse motors.
then i tried to brun the image to micro sd.
Now it works :slight_smile:
i think there must be something wrong with the rov suite image. …or the way it installs through software option in the dashbord


#5

@Finn Tore Johansen, an earlier RC had that problem but is has been fixed sense. -Brian


#6

@Tom-Vidar, I'll keep an eye open. I know this was being discussed on the forum. I'll respond there.


#7

Brian, I thought I was observing the problem with the latest version of RC6. The image file is OpenROV-2.5.1-101.img. Are you saying there is a newer version of RC6? - FT


#8

@FT, sorry, I misread your upgrade from as upgrade to. My bad.

The ROV gives up trying to get an DHCP address after 5 minutes, at which point it defaults to the 192.168.254.1 address. That is what those lines offer. Any chance the ROV was powered up for a while before being connected to a router or whaterver was handling out the address. I can tell you that it is working for the units I am testing with at the moment. I am very curious as to what might be happening.


#9

No, I don't think the 5-minute timeout could have expired. I had the ethernet cable connected before I powered on the ROV. My DHCP server is installed on the topside laptop, which is running linux and configured to do routing and natting for the ROV in addition to the browser.

I am giving the ROV an IP in the 192.168.1.2-100 range. When booting with the problematic lines in place, I could see DHCPDISCOVER and DHCPOFFER 192.168.1.2 on the topside syslog, but the ROV didn't respond to ping 192.168.1.2. After removing the lines, I saw DHCPDISCOVER, DHCPOFFER 192.168.1.2, DHCPREQUEST 192.168.1.2 and DHCPACK, and was able to ping, ssh, and browse as normal. I could go deeper into this with Wireshark if necessary. One idea that springs to mind is that the timeout value is set to 5 seconds, and not 5 minutes. Ref. http://manpages.ubuntu.com/manpages/trusty/man5/dhclient.conf.5.html.

FT


#10

I just tested with the following lines in /etc/dhcp/dhclient.conf, and now it works fine. :-)

timeout 300;
lease {
interface "eth0";
fixed-address 192.168.254.1;
option subnet-mask 255.255.255.0;
option routers 192.168.254.1;
renew 2 2037/1/12 00:00:01;
rebind 2 2037/1/12 00:00:01;
expire 2 2037/1/12 00:00:01;
}


#11

@Finn Thanks! That could explain things. All future DHCP users thank you!


#12

I am just an old time scuba diver. Does anyone have a up to date

program on an SD card or disk for a v2.7 running from a FireFox

Brouser on a Acer i5 lap top ?? Contact 702.630.1525