Issues with Update to v. 1.6.0 (RESOLVED)

I was super excited when the message cam in yesterday that a new update is released that enables recording of all the interesting data in an overlay over the HD video.
So obviously I went straight to a place with internet (backdrops of living on a boat) and started the update:
The cockpit app, easy
the update on the trident itself… I am on attempt 4 now (even left it overnight in a restaurant to have constant connection) but it seems it is downloading the file, and then the screen freezes on the “starting installation” bit of the process…
anyone had success to get it all done yet?

No Problem here, the whole update was done in less than 30 minutes.

1 Like

I wonder what my issue is here then… following the instructions step by step…

  • started with the cockpit app update
  • charge the trident to 100%
  • connect trident to tether and connect to app
  • connect trident to home network for internet
  • update is downloading
  • update “starts installing” and that is where it gets stuck for… well so far 3 hours is the high score before cancelling itself…

perhaps bad internet connection could be the issue?

Maybe restarting the tablet and resetting the app via the app manager helps.
Otherwise reach out to the support team. They will help you out.

1 Like

Thank you!
I will try that!

I had same issue! I shut everything down then rebooted and reconnected. After three attempts, it finally took. I would get to the last step and the screen would say “downloading” (with the active downward arrow) BUT it said "disconnected " at the lower part by the progress bar. I am on a very fast home connection!

Steve

same here… 4 attempts in it worked.
what I did in the end was I had the remote connected when that froze I connected the tablet computer and it asked me to update the firmware. so I OKyed that and it did its magic.
after restarting all was done it says up to date, the new features are in there and all is good!
Thanks for the input everyone!

1 Like

Thanks for bringing this up! Our software team is trying to figure out if there are similarities in the vehicles that are having trouble updating. I am glad that you were able to update your vehicles although it took awhile. :frowning:

1 Like

Hi there,

I tried to update the trident when using an hotel wifi. The process started correctly but the speed of the hotel’s internet connection was too slow: the download progress bar remained stuck on 2% for 30 min at least.

For this reason I aborted the update. However it was not clear if the app was aborting the process, so I turned off the ROV and the controller.
After this, I switched on the trident and the pilot app to check if it was possible to fly it and everything appeared normal.

The next day I started the trident again to fly it and the pilot app showed a message saying that it was necessary to update the firmware before being able to fly the rov. It appeared a firmware update screen with 4 step which after few minute were completed.

I was then able to use the trident although in 2 or 3 occasion I lost the wifi connection with the buoy (i.e. the leds turned off) while the trident was in the water. Every time the connection re-established (don’t remember if I unplugged/re-plugged the buoy) and I was able to continue.

Once I got home with a stable and fast internet connection, I wanted to complete the update properly. However, now the maintenance tool of the pilot app says that the system is up to date and so I am not able to restart the update process.

Considering I aborted the download process I am afraid that the update could not be complete or 100% successful.

Is it possible to redo the update? Alternatively Can I be sure that the update has been successfully completed? how can I check?

Thank you.

If you go to the maintenance screen in the app, an up to date system (as of time of this writing)
Android App Version: 1.6.0
Trident software version: 27a3f6

Alternatively, you can email support@sofarocean.com with your serial number and we can check it out on our end.

If you are experiencing disconnects where the topside lights are turning off this normally happens if the connector on the vehicle and/or topside are not tight enough. When you are attaching the tether, make sure it is tight.

1 Like