Issue with dive lights kicking off

software
electronics

#1

So we have been having a problem with a few of our 2.7 units where they will randomly shut off the led lights while diving. We will be diving for approximately 15-20 minutes and the lights will turn off. If we turn them, back on they stay on for a short while, then shut off again. Has anyone have this problem before? This has happened with more than one unit too.


#2

Last night, on dive #3 for my ROV, I had the lights go off a few times. I was able to bring them back up immediately, though, so I didn’t think too much of it.


#3

There are two likely causes that come to mind:

  1. The Arduino has reset. If the runtime in the lower right resets to zero, that is an indication that Arduino has rest.

  2. If the Arduino does not receive and heartbeat signal from the browser after a minute it will stop the motors and flash the lights. I may need to widen the gap as it appears there are cases where the Arduino appears to give up waiting on the heartbeat and then almost immediately gets it. The two possible reasons for an inconsistent receipt of the heart beat are
    a. Communication lag. Either the homeplug momentarily disconnect or some other interference is causing delays in the network traffic beteen the beaglebone and the browser.
    b. The browser is falling behind in sending the heartbeats. This does happen if the browser window does not have focus (Chrome then runs the javascript on the browser at a much lower priority). This could also happen if the computer in general is running out of horse power.


#4

Which file would I modify to adjust the amount of time between heartbeets located? I need to change this ASAP.


#5

No problem:

You can change it here from 2000ms to whatever you would like:
https://github.com/OpenROV/openrov-software-arduino/blob/master/OpenROV/DeadManSwitch.cpp#L40

Of you can simply disable the feature all together by changing the line below from a 1 to a 0.
https://github.com/OpenROV/openrov-software-arduino/blob/master/OpenROV/AConfig.h#L31


#6

I just completed a dive about an hour ago, and the light issue was much more pronounced. They would turn off while the thrusters were powering the ROV around, and no other system appeared to be affected at all when the lights conked out. I was still able to bring the lights right back, however they would go out once again a few minutes later.


#7

Thank you so much for the fast reply!


#8

@parson-nicholas

I had the same issue last night, we’re going to do night dives tonight, but it seemed that the lights would shut off again in less than one minute. The other thing is, I noticed my IMU getting weird afterward too, but it was back to normal after a restart.


#9

@badevguru is this a config file that is editable on the ROV its self, or would I have to download the source, change it and compile it and transfer it over to the ROV?


#10

Editable on the ROV itself.

The actual files are in /opt/openrov/arduino/OpenROV

I believe you can get to them using the built in web editor “Cloud9” that you can start from the dashboard (http://192.168.254.1)

Or you can ssh on to the ROV and change them using the pico text editor.

You much re-upload the Arduino firmware via the settings tab after making and saving the changes to the text files for them to be applied to your ROV.


#11

I found it a second after posting, thanks again!


#12

I’m trying to get to the AConfig.h file to turn off the deadman switch (I really have no idea what I’m doing, but I’m trying to learn as I go along!) and am using Cloud9. However, when I click on the file to open it, it’s blank. What am I missing?


#13

If you first open up cloud9 and it gives you a session error message you will need to refresh the browser until you no longer get that message.


#14

I didn’t receive any error messages, so it must be something that I am doing incorrectly. I went to the dashboard, clicked “start” under Cloud9, entered Cloud9 once it said “running” on the dashboard, then clicked openrov -> arduino -> OpenROV -> Aconfig.h. That’s how I got to where I am in the screenshot above.


#15

Well shoot. I just fired up mine and see the same symptoms. Looks like a key file is missing or unable to load. I’ll have to take a look tonight. Sorry, no quick fix for using Cloud9.

The work around is going to have to be ssh’ing on to the ROV and using the pico program to change the file.

https://github.com/OpenROV/openrov-image/issues/84


#16

Thanks for taking a look! I still need to learn up on SSHing to the ROV, so I’ll wait for the Cloud9 issue to be resolved. The light issue has been more of a small nuisance than a real problem.