Is my HomePlug adaptor fried?


#1

I hooked up all the electrics for the ROV to do a bench test.

On the topside adaptor I have the lights for Power and Network (the laptop) lit up but nothing on the light showing a connection to another HomePlug.

On checking the HomePlug on the ROV there were no lights on at all so I connected some bench power to the ROV HomePlug and sent 3.3v to it and the Network light comes on (for a bit then goes off) but not the power light.

Any ideas?


#2

Very strange. I have actually witnessed something like this with our own ROV-side homeplug adapters with no explanation. Everything will be plugged in and I get good continuity, but no lights. Eventually, it starts working after I'm about to give up. I think it could possibly have to do with the system struggling to provide enough current to the adapter.

The best advice I can offer is test continuity with everything, make sure there are no shorts, and try power-cycling it a few times.

Good luck!

Eric


#3

After connecting the HomePlug direct to some bench power and doing a few power cycles I managed to get lights on in the right places on the HomePlug.

I reconnected it to the BeagleBone but still nothing. Using a multimeter across 3.3v and Gnd on the board gives a reading of 0. Whereas across 5v and Gnd gives a reading of 4.9v and Vin and Gnd gives a reading of 11v so now I am thinking there is a problem with the BeagleBone and it's not actually sending power to the HomePlug board?


#4

I had connected the 3.3v in reverse once from the BB to the HomePlug and it caused similar issues as you describe but once I reversed it back and power cycled the BB all was ok. I know this is a simple thing but make sure the polarity is correct. Also disconnect the Homeplug adapter and check the 3.3v voltage on the BB after power cycling it once or twice.


#5

Thanks David, I think I had too much wire sticking out the other side of the board and it was shorting somewhere. I took the HomePlug off and got 3.3v on the board and when I resoldered the HomePlug power leads it started getting power.

I'm still not quite there though as now I have the two lights on both the HomePlug board for power and network but no middle light for the connection between the two HomePlugs.

Any suggestions?


#6

When testing the Homeplug adapetrs use a standard patch cable between the homeplug and the BB do the same on the top side between the Homeplug and the Computer. Also make sure you are using 192.168.254.2 subnet 255.255.255.0 as an example for your computer's ip address. The Ip of the BB by default is set to 192.168.254.1

If you are plugging the Homeplug into a router then there is no need to change the ip as it should get one using DHCP.


#7

Still no joy I'm afraid :(

I actually connected the tether connections of the two HomePlug together but a jumper of just a couple of inches but still no elusive third light.

Is there any sure fire way of testing that the two HomePlug boards can see each other?


#8

This still does not tell me if you tried using standard of the shelf patch cables.

I just wanted to make sure you are using the correct twisted pair wiring between the HomePlug adapter and the BB.

Another test to check the HomePlug Adapters would be to have them powered up and connect your laptop to the Topside Homeplug adapter and use a patch cable and connect your other Homeplug adapter using another patch cable to your Home network router, you should be able to connect to the internet via the Homeplug adapters.


#9

I'm using the two cables that came with the HomePlug adaptors to connect from the BB to the HomePlug and the Topside HomePlug to my laptop.

I tried connecting my laptop to the topside adapter and the ROV side adapter to my router but nothing. Just the same two lights (Power and Network cable I believe) and nothing from the light that should come on when two HomePLugs can "see" each other.

I've attached a pic of my testing rig (ROV adapter plugging into router) if that is of any help.

Thanks again for your help David.



#10

for what it's worth try using different patch cables as you may have one that is bad or test each one using your laptop to your router just to make sure they work ok. also check the pins in the RJ45 receptacles to make sure no pins are missing, bent or shorted together.


#11

"for what it's worth try using different patch cables as you may have one that is bad or test each one using your laptop to your router just to make sure they work ok. also check the pins in the RJ45 receptacles to make sure no pins are missing, bent or shorted together."

I tried both the patch cables from my laptop to my router and they worked fine. Both the RJ45 receptacles look in good order as well.

I also connected my BB to my router with one of the patch cables and it shows up on my router as "OpenROV" and I can connect with my browser and see a camera image.

All I can think of is that I have a duff HomePlug board :(


#12

I remade all my solder connections and still the same problem (the homeplugs aren't talking to each other).

I downloaded the Medialink Powerline Utility and both of the adapters register on it but only when each one is directly connected to the laptop, I can't connect to one and have the utility see them both on their own network.

Does anyone know if the Medialink Homeplugs are sold under another name in the UK?


#13

Sorry to hear that your are not having much luck to get this to work.

Here is a Link to Amazon which I think will ship to your location.

http://www.amazon.com/Medialink-HomePlug-Powerline-Ethernet-Adapters/dp/B004UGPCMQ


#14

Hi Owen

Tenda P200 is the same I got mine from eBay in the uk link here showing mine http://www.underwaterrov.net/openrov-build-stage-7-the-tether